summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-10 03:58:50 +0000
committerSam James <sam@gentoo.org>2023-01-10 03:58:50 +0000
commitd7dfbe07d62ea779acb5054b0adbe4ca0ba40e1c (patch)
tree0acbaeae4edba1c714e83b863d1cb6ab9adb1dac /media-gfx
parentapp-portage/recover-broken-vdb: crank pax-utis dep (diff)
downloadgentoo-d7dfbe07d62ea779acb5054b0adbe4ca0ba40e1c.tar.gz
gentoo-d7dfbe07d62ea779acb5054b0adbe4ca0ba40e1c.tar.bz2
gentoo-d7dfbe07d62ea779acb5054b0adbe4ca0ba40e1c.zip
media-gfx/scrot: add 1.8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/scrot/Manifest1
-rw-r--r--media-gfx/scrot/scrot-1.8.ebuild60
-rw-r--r--media-gfx/scrot/scrot-9999.ebuild3
3 files changed, 62 insertions, 2 deletions
diff --git a/media-gfx/scrot/Manifest b/media-gfx/scrot/Manifest
index 1e2a8e8b5831..e45f5018b0c7 100644
--- a/media-gfx/scrot/Manifest
+++ b/media-gfx/scrot/Manifest
@@ -1 +1,2 @@
DIST scrot-1.7.tar.gz 178463 BLAKE2B 021c68c5ebd19ec08c072cff73fe1ebb7ffd179dfcde6e13656779e2ee1357cf0fdbba1d4beb2fc5dc9c8c4cd28008acaa462068eec3192cea6687ac58cd653a SHA512 3ef2b547d561a85213ef0075af3034020f00168253d3b84ef94578f0b8534f9a7389c808f8fcd0c619358a14f41601fee407d08d63c397b9892ba9fc2db23f88
+DIST scrot-1.8.tar.gz 175453 BLAKE2B 2c6cd9c6d8ea7b2dbdfa4827af52ead01327556565d957c3fc37d8511aed3247b02e61f97e1d4136fc047062fa7ff5c01f2a12b290620d2a8572b813c73413b2 SHA512 64d74da0afb4249687b757206baca704911cab34e15e56e7328d259bdb2daf984c0cd5bcd0764c7688c4340b3453cac9d6af1ce750fa65c8d7a31992dff1fcea
diff --git a/media-gfx/scrot/scrot-1.8.ebuild b/media-gfx/scrot/scrot-1.8.ebuild
new file mode 100644
index 000000000000..a7f14945b8f4
--- /dev/null
+++ b/media-gfx/scrot/scrot-1.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Screen capture utility using imlib2 library"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/scrot"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/resurrecting-open-source-projects/${PN}"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="feh LGPL-2+"
+SLOT="0"
+
+# imlib2[X] needed for imlib_create_image_from_drawable, bug #835582
+RDEPEND="
+ dev-libs/libbsd
+ media-libs/imlib2[X]
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXfixes
+ || (
+ media-libs/imlib2[gif]
+ media-libs/imlib2[jpeg]
+ media-libs/imlib2[png]
+ media-libs/imlib2[tiff]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ elibc_musl? ( sys-libs/queue-standalone )
+"
+BDEPEND="
+ sys-devel/autoconf-archive
+ virtual/pkgconfig
+"
+
+DOCS=(
+ AUTHORS ChangeLog README.md
+)
+
+src_prepare() {
+ default
+
+ [[ ${PV} == *9999* ]] && eautoreconf
+}
+
+src_install() {
+ default
+
+ newbashcomp "${FILESDIR}"/${PN}-1.7.bash-completion ${PN}
+}
diff --git a/media-gfx/scrot/scrot-9999.ebuild b/media-gfx/scrot/scrot-9999.ebuild
index a99487cdc4e9..a7f14945b8f4 100644
--- a/media-gfx/scrot/scrot-9999.ebuild
+++ b/media-gfx/scrot/scrot-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,6 @@ if [[ ${PV} == *9999* ]] ; then
inherit autotools git-r3
else
SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/releases/download/${PV}/${P}.tar.gz"
-
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi