summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-07 14:58:23 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-07 14:59:02 +0200
commite4a3c2ef0e7dad033886a82881e495c4ef67453a (patch)
tree162c0dc5e567baa52aed4bed5da59bce7b6598c5 /media-gfx
parentapp-i18n/fbterm: tidy (diff)
downloadgentoo-e4a3c2ef0e7dad033886a82881e495c4ef67453a.tar.gz
gentoo-e4a3c2ef0e7dad033886a82881e495c4ef67453a.tar.bz2
gentoo-e4a3c2ef0e7dad033886a82881e495c4ef67453a.zip
media-gfx/inkscape: Use pkg-config to find freetype
Bug: https://bugs.gentoo.org/655130 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/inkscape/files/inkscape-0.92.3-freetype_pkgconfig.patch18
-rw-r--r--media-gfx/inkscape/inkscape-0.92.3.ebuild43
2 files changed, 41 insertions, 20 deletions
diff --git a/media-gfx/inkscape/files/inkscape-0.92.3-freetype_pkgconfig.patch b/media-gfx/inkscape/files/inkscape-0.92.3-freetype_pkgconfig.patch
new file mode 100644
index 000000000000..0f577bd0e9ab
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-0.92.3-freetype_pkgconfig.patch
@@ -0,0 +1,18 @@
+--- inkscape-0.92.3/configure.ac
++++ inkscape-0.92.3/configure.ac
+@@ -252,12 +252,9 @@
+ [#include <malloc.h>])
+ ])
+
+-AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no)
+-if test "x$FREETYPE_CONFIG" = "xno"; then
+- AC_MSG_ERROR([Cannot find freetype-config])
+-fi
+-FREETYPE_CFLAGS=`$FREETYPE_CONFIG --cflags`
+-FREETYPE_LIBS=`$FREETYPE_CONFIG --libs`
++PKG_CHECK_MODULES(FREETYPE, freetype2,,
++ AC_MSG_ERROR([Cannot find freetype])
++)
+ AC_SUBST(FREETYPE_CFLAGS)
+ AC_SUBST(FREETYPE_LIBS)
+
diff --git a/media-gfx/inkscape/inkscape-0.92.3.ebuild b/media-gfx/inkscape/inkscape-0.92.3.ebuild
index 69b0c27405f4..cc1ee8f61d9e 100644
--- a/media-gfx/inkscape/inkscape-0.92.3.ebuild
+++ b/media-gfx/inkscape/inkscape-0.92.3.ebuild
@@ -7,7 +7,7 @@ PYTHON_REQ_USE="xml"
inherit autotools flag-o-matic gnome2-utils xdg toolchain-funcs python-single-r1
-MY_P=${P/_/}
+MY_P="${P/_/}"
DESCRIPTION="A SVG based generic vector-drawing program"
HOMEPAGE="https://inkscape.org/"
@@ -100,9 +100,10 @@ PATCHES=(
"${FILESDIR}/${PN}-0.91_pre3-exif.patch"
"${FILESDIR}/${PN}-0.91_pre3-sk-man.patch"
"${FILESDIR}/${PN}-0.48.4-epython.patch"
+ "${FILESDIR}/${PN}-0.92.3-freetype_pkgconfig.patch"
)
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
RESTRICT="test"
@@ -128,23 +129,25 @@ src_configure() {
# aliasing unsafe wrt #310393
append-flags -fno-strict-aliasing
- econf \
- $(use_enable static-libs static) \
- $(use_enable nls) \
- $(use_enable openmp) \
- $(use_enable exif) \
- $(use_enable jpeg) \
- $(use_enable lcms) \
- --enable-poppler-cairo \
- $(use_enable wpg) \
- $(use_enable visio) \
- $(use_enable cdr) \
- $(use_enable dbus dbusapi) \
- $(use_enable imagemagick magick) \
- $(use_with gnome gnome-vfs) \
- $(use_with inkjar) \
- $(use_with spell gtkspell) \
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable nls)
+ $(use_enable openmp)
+ $(use_enable exif)
+ $(use_enable jpeg)
+ $(use_enable lcms)
+ --enable-poppler-cairo
+ $(use_enable wpg)
+ $(use_enable visio)
+ $(use_enable cdr)
+ $(use_enable dbus dbusapi)
+ $(use_enable imagemagick magick)
+ $(use_with gnome gnome-vfs)
+ $(use_with inkjar)
+ $(use_with spell gtkspell)
$(use_with spell aspell)
+ )
+ econf "${myeconfargs[@]}"
}
src_compile() {
@@ -154,8 +157,8 @@ src_compile() {
src_install() {
default
- prune_libtool_files
- python_optimize "${ED}"/usr/share/${PN}/extensions
+ find "${ED}" -name "*.la" -delete || die
+ python_optimize "${ED%/}"/usr/share/${PN}/extensions
}
pkg_preinst() {