summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-06-27 14:03:59 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-06-27 14:06:11 +0200
commitff4e76bd91741c20f4c93c94dfb3366c5df24737 (patch)
tree29dfa3264ec9559f2570bf2a262ff64ca458a4e4 /media-gfx
parentdev-python/sympy: Remove old (diff)
downloadgentoo-ff4e76bd91741c20f4c93c94dfb3366c5df24737.tar.gz
gentoo-ff4e76bd91741c20f4c93c94dfb3366c5df24737.tar.bz2
gentoo-ff4e76bd91741c20f4c93c94dfb3366c5df24737.zip
media-gfx/libredwg: add 0.12.5.5865
patch for CVE-2022-35164 is in this version Bug: https://bugs.gentoo.org/856034 Bug: https://bugs.gentoo.org/905327 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/libredwg/Manifest1
-rw-r--r--media-gfx/libredwg/libredwg-0.12.5.5865.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/media-gfx/libredwg/Manifest b/media-gfx/libredwg/Manifest
index 8588df408d02..9dcea6be5e78 100644
--- a/media-gfx/libredwg/Manifest
+++ b/media-gfx/libredwg/Manifest
@@ -1,3 +1,4 @@
DIST libredwg-0.12.5.5487.tar.gz 18878778 BLAKE2B 01f6960dc1bab65e447f942d1a198d6ddcef0043ed50e7b58ea4dbb5d52bf25e4d0946170f66455b0ae00e08352d45710546c62e623b1522a6681bf7ea51683e SHA512 8883d0bc6a893fc10960ecd8cb1d32833c955e87b18817194e746e481f6d1ea5587bfb54e8da7ae975d8b3f93bf89a2611c97710449848e1274e734e3443ad52
+DIST libredwg-0.12.5.5865.tar.gz 18891945 BLAKE2B d779963d29c484e806549a530655041000c79277bbd53795b81b211e63c18e9aa112fa6b6f495dd6f950ac70019cae000b28c76c531d0d942e349ab92295e10a SHA512 24443ca405b33347f43dddf46346b23cb76e5209a7e4451bb5cfc467569df0784cea86a96aaf349aa7b59adb5c38059292ca3c8a831796232fd29b3fad6240b6
DIST libredwg-0.12.5.tar.gz 16855123 BLAKE2B 2ca0bfafdb0ca6e412d3aaf7df21f80a2eed4bad795bffacc1c767f23dc555b35b2aeedb35dffab099c5dbab2890f9363cfc1508c3fec16a6ff51ce79a272e3e SHA512 0b5da6e863410d9ce012d311e921a39fa0d9cb6d96d17f1df70ca767c1768cd625e35503f24830a6a33400ede92d14b36ce87b92f177a5af7e6d4573920cf50c
DIST libredwg-85695f3d5903b1cd5b4030efe50db3b4f5f3c928.tar.gz 12597 BLAKE2B cd01f6c446d5d129545fdae07c0101d133e1f4e69ee62e94c27c3c2853dcc30854f40aed0c6f38f6594c5f5eb9e7b2d18d3b2e4f487b7bf1a3f7f39facde38bc SHA512 1d08cfa6216e0fe671dab77a0bd0b4ef0c4eb174878eba909c680e0ee93a82079b3cbf60afe2de7b0078258de8bcc588961e59cf0c14fe5f2d1f70db639ef95a
diff --git a/media-gfx/libredwg/libredwg-0.12.5.5865.ebuild b/media-gfx/libredwg/libredwg-0.12.5.5865.ebuild
new file mode 100644
index 000000000000..2dde554209f8
--- /dev/null
+++ b/media-gfx/libredwg/libredwg-0.12.5.5865.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DOCS_BUILDER="doxygen"
+# File is hardcoded to be run from ../ so we use this instead of DOCS_DIR
+DOCS_CONFIG_NAME="doc/Doxyfile"
+
+inherit autotools docs python-single-r1 perl-functions
+
+JSMN_COMMIT="85695f3d5903b1cd5b4030efe50db3b4f5f3c928"
+
+DESCRIPTION="C library to handle DWG files"
+HOMEPAGE="https://www.gnu.org/software/libredwg/"
+SRC_URI="
+ https://github.com/LibreDWG/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/zserge/jsmn/archive/${JSMN_COMMIT}.tar.gz -> ${PN}-${JSMN_COMMIT}.tar.gz
+"
+
+LICENSE="GPL-3+ MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# https://github.com/LibreDWG/libredwg/issues/342
+RESTRICT="test"
+
+IUSE="debug python perl static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+ perl? ( dev-lang/perl )
+ dev-libs/libpcre2
+ dev-libs/pslib
+"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ perl? ( dev-lang/swig )
+"
+BDEPEND="|| (
+ sys-devel/gcc[sanitize]
+ sys-libs/compiler-rt-sanitizers[asan(-)]
+ )
+ dev-vcs/git
+"
+
+src_unpack() {
+ # Build system really wants jsmn to be here
+ default
+ rm -r "${S}/jsmn" || die
+ mv "${WORKDIR}/jsmn-${JSMN_COMMIT}" "${S}/jsmn" || die
+}
+
+src_prepare() {
+ default
+ # Fix variable references itself error, fails in src_install otherwise.
+ sed -i -e 's/TEXINPUTS="$(TEXINPUTS)$(PATH_SEPARATOR)$(TEXINFO_TEX_DIR)"/TEXINPUTS="$(PATH_SEPARATOR)$(TEXINFO_TEX_DIR)"/g' doc/Makefile.am || die
+ # https://github.com/LibreDWG/libredwg/issues/404
+ # Workaround: release tarball does not include dwg2ps.1.
+ # Upstream autotools stuff has to be run in git repo
+ git init -q || die
+ git config --global user.email "larry@gentoo.org" || die
+ git config --global user.name "Larry the Cow" || die
+ git add . || die
+ git commit -qm 'init' || die
+ git tag ${PV} || die
+ eautoreconf
+}
+
+src_configure() {
+ perl_set_version
+ local myconf=(
+ --enable-write
+ --enable-dxf
+ --enable-json
+ --disable-gcov
+ $(use_enable !debug release)
+ $(use_enable debug trace)
+ $(use_enable debug)
+ $(use_enable static-libs static)
+ $(use_enable python python "${EPYTHON}")
+ $(usex perl "--with-perl-install=vendor" "--with-perl-install=no")
+ )
+
+ if use python || use perl; then
+ myconf+=( --enable-bindings )
+ else
+ myconf+=( --disable-bindings )
+ fi
+
+ econf ${myconf[@]}
+}
+
+src_compile() {
+ perl_set_version
+ emake
+ docs_compile
+}
+
+src_install() {
+ perl_set_version
+ default
+ use python && python_optimize
+ # remove .la files if static-libs disabled
+ if ! use static-libs; then
+ rm "${ED}/usr/$(get_libdir)/libredwg.la" || die
+ if use python; then
+ rm "${D}/$(python_get_sitedir)/_LibreDWG.la" || die
+ fi
+ fi
+}