summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2017-09-21 09:58:57 +0100
committerDavid Seifert <soap@gentoo.org>2017-09-23 10:32:32 +0200
commitca3952cdeccf9e3c6bd6973e3ed1c0681857aceb (patch)
tree45d781835ea108934a29a10adc6f9f3eb1ca9f88 /media-libs/Field3D
parentprofiles: mask flags for unkeyworded depends (diff)
downloadgentoo-ca3952cdeccf9e3c6bd6973e3ed1c0681857aceb.tar.gz
gentoo-ca3952cdeccf9e3c6bd6973e3ed1c0681857aceb.tar.bz2
gentoo-ca3952cdeccf9e3c6bd6973e3ed1c0681857aceb.zip
media-libs/Field3D: New package
Field3D is an open source library for storing voxel data. It provides C++ classes that handle in-memory storage and a file format based on HDF5 that allows the C++ objects to be written to and read from disk. This is a new dependency for OpenImageIO. Closes: https://github.com/gentoo/gentoo/pull/5748
Diffstat (limited to 'media-libs/Field3D')
-rw-r--r--media-libs/Field3D/Field3D-1.7.2.ebuild28
-rw-r--r--media-libs/Field3D/Manifest1
-rw-r--r--media-libs/Field3D/files/Field3D-1.7.2-openexr-fixes.patch38
-rw-r--r--media-libs/Field3D/metadata.xml25
4 files changed, 92 insertions, 0 deletions
diff --git a/media-libs/Field3D/Field3D-1.7.2.ebuild b/media-libs/Field3D/Field3D-1.7.2.ebuild
new file mode 100644
index 000000000000..414b9351f9f1
--- /dev/null
+++ b/media-libs/Field3D/Field3D-1.7.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A library for storing voxel data"
+HOMEPAGE="http://opensource.imageworks.com/?p=field3d"
+SRC_URI="https://github.com/imageworks/Field3D/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-libs/boost-1.62:=
+ >=media-libs/ilmbase-2.2.0:=
+ sci-libs/hdf5:=
+ virtual/mpi"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/Field3D-1.7.2-openexr-fixes.patch" )
+
+# Docs are not finished yet.
+mycmakeargs=( -DINSTALL_DOCS=OFF )
diff --git a/media-libs/Field3D/Manifest b/media-libs/Field3D/Manifest
new file mode 100644
index 000000000000..4f9c43edc4fc
--- /dev/null
+++ b/media-libs/Field3D/Manifest
@@ -0,0 +1 @@
+DIST Field3D-1.7.2.tar.gz 502481 SHA256 8f7c33ecb4489ed626455cf3998d911a079b4f137f86814d9c37c5765bf4b020 SHA512 e4ea51310105980f759dce48830db8ae3592ce32a02b246214d8aed9df7a7f5c500314f2daf92196b7a76d648f2909b18112df4c5c3c8949c0676d710dfbf1f2 WHIRLPOOL c29702dc0c2f15c65d92871ef82059aa35b9fb7927d9510b496511c8de21f160298cf9b32717d0fbac7a5c1656f5c5757a3d1fe3fdb00121d2100664412b65d2
diff --git a/media-libs/Field3D/files/Field3D-1.7.2-openexr-fixes.patch b/media-libs/Field3D/files/Field3D-1.7.2-openexr-fixes.patch
new file mode 100644
index 000000000000..41ab1ccf2945
--- /dev/null
+++ b/media-libs/Field3D/files/Field3D-1.7.2-openexr-fixes.patch
@@ -0,0 +1,38 @@
+diff -purN a/cmake/FindILMBase.cmake b/cmake/FindILMBase.cmake
+--- a/cmake/FindILMBase.cmake 2016-06-19 05:56:00.000000000 +0100
++++ b/cmake/FindILMBase.cmake 2017-03-02 11:44:35.449043588 +0000
+@@ -37,12 +37,17 @@
+ # ILMBASE_FOUND - true if ILMBASE was found on the system
+ # ILMBASE_LIBRARY_DIRS - the full set of library directories
+
++find_package(PkgConfig QUIET)
++if(PKG_CONFIG_FOUND)
++ pkg_check_modules(PC_ILMBASE QUIET IlmBase)
++endif()
++
+ FIND_PATH ( Ilmbase_Base_Dir include/OpenEXR/IlmBaseConfig.h
+ ENV ILMBASE_ROOT
+ )
+
+ IF ( Ilmbase_Base_Dir )
+-
++ SET ( IlmBase_VERSION ${PC_ILMBASE_VERSION} )
+ SET ( ILMBASE_INCLUDE_DIRS
+ ${Ilmbase_Base_Dir}/include
+ ${Ilmbase_Base_Dir}/include/OpenEXR
+diff -purN a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2016-06-19 05:56:00.000000000 +0100
++++ b/CMakeLists.txt 2017-03-02 11:44:37.029035041 +0000
+@@ -146,8 +146,11 @@ IF ( CMAKE_HOST_UNIX )
+ LIST ( APPEND Field3D_Libraries_Shared
+ ${MPI_LIBRARIES} )
+ ENDIF ( MPI_FOUND )
++ # handle new library names for 2.0.0
++ STRING ( REPLACE "." "_" _IlmBase_VERSION ${IlmBase_VERSION} )
++ STRING ( SUBSTRING ${_IlmBase_VERSION} 0 3 _IlmBase_VERSION )
+ LIST ( APPEND Field3D_Libraries_Shared
+- Iex Half IlmThread Imath
++ Iex-${_IlmBase_VERSION} Half IlmThread-${_IlmBase_VERSION} Imath-${_IlmBase_VERSION}
+ pthread dl z )
+ SET ( Field3D_DSO_Libraries ${Field3D_Libraries_Shared} )
+ SET ( Field3D_BIN_Libraries Field3D ${Field3D_Libraries_Shared}
diff --git a/media-libs/Field3D/metadata.xml b/media-libs/Field3D/metadata.xml
new file mode 100644
index 000000000000..2e6a3587ddce
--- /dev/null
+++ b/media-libs/Field3D/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>j.scruggs@gmail.com</email>
+ <name>Jonathan Scruggs</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>agrigo2001@yahoo.com.au</email>
+ <name>Adrian Grigo</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Field3D is an open source library for storing voxel data.
+ It provides C++ classes that handle in-memory storage and
+ a file format based on HDF5 that allows the C++ objects
+ to be written to and read from disk.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">imageworks/Field3D</remote-id>
+ </upstream>
+</pkgmetadata>