summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2017-09-23 16:27:43 +0100
committerDavid Seifert <soap@gentoo.org>2017-09-23 17:47:22 +0200
commitd0cabeca83fd2052ffa6b7c57d092a944b3ef190 (patch)
treeb11f1aa7f6087395b42d3ce273116ff57945b082 /media-libs/Field3D
parentapp-editors/emacs: Remove old. (diff)
downloadgentoo-d0cabeca83fd2052ffa6b7c57d092a944b3ef190.tar.gz
gentoo-d0cabeca83fd2052ffa6b7c57d092a944b3ef190.tar.bz2
gentoo-d0cabeca83fd2052ffa6b7c57d092a944b3ef190.zip
media-libs/Field3D: Fix compiling error for some people
* Replaced patch with more robust one to fix an error that causes the compile phase to stop. Closes: https://bugs.gentoo.org/631832
Diffstat (limited to 'media-libs/Field3D')
-rw-r--r--media-libs/Field3D/Field3D-1.7.2.ebuild2
-rw-r--r--media-libs/Field3D/files/Field3D-1.7.2-Use-PkgConfig-for-IlmBase.patch142
-rw-r--r--media-libs/Field3D/files/Field3D-1.7.2-openexr-fixes.patch38
3 files changed, 143 insertions, 39 deletions
diff --git a/media-libs/Field3D/Field3D-1.7.2.ebuild b/media-libs/Field3D/Field3D-1.7.2.ebuild
index 414b9351f9f1..780a06db52ea 100644
--- a/media-libs/Field3D/Field3D-1.7.2.ebuild
+++ b/media-libs/Field3D/Field3D-1.7.2.ebuild
@@ -22,7 +22,7 @@ RDEPEND="
DEPEND="${RDEPEND}
virtual/pkgconfig"
-PATCHES=( "${FILESDIR}/Field3D-1.7.2-openexr-fixes.patch" )
+PATCHES=( "${FILESDIR}/Field3D-1.7.2-Use-PkgConfig-for-IlmBase.patch" )
# Docs are not finished yet.
mycmakeargs=( -DINSTALL_DOCS=OFF )
diff --git a/media-libs/Field3D/files/Field3D-1.7.2-Use-PkgConfig-for-IlmBase.patch b/media-libs/Field3D/files/Field3D-1.7.2-Use-PkgConfig-for-IlmBase.patch
new file mode 100644
index 000000000000..e967d20244c3
--- /dev/null
+++ b/media-libs/Field3D/files/Field3D-1.7.2-Use-PkgConfig-for-IlmBase.patch
@@ -0,0 +1,142 @@
+From 5656d8dc657f4702c67fbabfab8922c80e0cf778 Mon Sep 17 00:00:00 2001
+From: Jonathan Scruggs <j.scruggs@gmail.com>
+Date: Sat, 23 Sep 2017 16:08:48 +0100
+Subject: [PATCH] Use PkgConfig for IlmBase
+
+---
+ CMakeLists.txt | 15 +++++++-------
+ cmake/FindILMBase.cmake | 54 -------------------------------------------------
+ 2 files changed, 8 insertions(+), 61 deletions(-)
+ delete mode 100644 cmake/FindILMBase.cmake
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e9ad44f..864f0d2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -35,8 +35,9 @@ CMAKE_MINIMUM_REQUIRED( VERSION 2.8 )
+
+ PROJECT ( field3d )
+
+-set( CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${PROJECT_SOURCE_DIR}/cmake )
++set( CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} )
+
++FIND_PACKAGE ( PkgConfig )
+ FIND_PACKAGE (Doxygen)
+ FIND_PACKAGE (HDF5)
+ IF ( CMAKE_HOST_WIN32 )
+@@ -49,7 +50,7 @@ FIND_PACKAGE (Boost COMPONENTS regex thread program_options system)
+ FIND_PACKAGE (MPI)
+ ENDIF ()
+
+-FIND_PACKAGE (ILMBase)
++PKG_CHECK_MODULES ( ILMBASE_LIBS REQUIRED IlmBase )
+
+ # Allow the developer to select if Dynamic or Static libraries are built
+ OPTION (BUILD_SHARED_LIBS "Build Shared Libraries" ON)
+@@ -65,14 +66,14 @@ INCLUDE_DIRECTORIES ( . )
+ INCLUDE_DIRECTORIES ( src )
+ INCLUDE_DIRECTORIES ( export )
+ INCLUDE_DIRECTORIES ( include )
+-INCLUDE_DIRECTORIES ( ${ILMBASE_INCLUDE_DIRS} )
++INCLUDE_DIRECTORIES ( SYSTEM ${ILMBASE_LIBS_INCLUDE_DIRS} )
+ INCLUDE_DIRECTORIES ( ${HDF5_INCLUDE_DIRS} )
+ INCLUDE_DIRECTORIES ( ${Boost_INCLUDE_DIR} )
+
+ # link directories
+ LINK_DIRECTORIES ( ${Boost_LIBRARY_DIRS} )
+ LINK_DIRECTORIES ( ${HDF5_LIBRARY_DIRS} )
+-LINK_DIRECTORIES ( ${ILMBASE_LIBRARY_DIRS} )
++LINK_DIRECTORIES ( ${ILMBASE_LIBS_LIBRARY_DIRS} )
+
+ IF ( CMAKE_HOST_UNIX )
+ ADD_DEFINITIONS ( -fPIC -DREQUIRE_IOSTREAM -Wno-invalid-offsetof )
+@@ -147,7 +148,7 @@ IF ( CMAKE_HOST_UNIX )
+ ${MPI_LIBRARIES} )
+ ENDIF ( MPI_FOUND )
+ LIST ( APPEND Field3D_Libraries_Shared
+- Iex Half IlmThread Imath
++ ${ILMBASE_LIBS_LIBRARIES}
+ pthread dl z )
+ SET ( Field3D_DSO_Libraries ${Field3D_Libraries_Shared} )
+ SET ( Field3D_BIN_Libraries Field3D ${Field3D_Libraries_Shared}
+@@ -155,7 +156,7 @@ IF ( CMAKE_HOST_UNIX )
+ ENDIF ( )
+ IF ( CMAKE_HOST_WIN32 )
+ # Add OpenEXR and zlib release/debug
+- FOREACH ( lib Iex Half IlmThread Imath zdll )
++ FOREACH ( lib ${ILMBASE_LIBS_LIBRARIES} zdll )
+ LIST ( APPEND Field3D_Libraries_Shared
+ optimized ${lib}
+ debug ${lib}_d )
+@@ -164,7 +165,7 @@ IF ( CMAKE_HOST_WIN32 )
+ SET ( Field3D_BIN_Libraries Field3D ${Boost_LIBRARIES} )
+ ENDIF ()
+
+-TARGET_LINK_LIBRARIES ( Field3D ${Field3D_DSO_Libraries} ${Boost_LIBRARIES})
++TARGET_LINK_LIBRARIES ( Field3D ${Field3D_DSO_Libraries} ${Boost_LIBRARIES} )
+
+ # Parase version and soversion from export/ns.h
+
+diff --git a/cmake/FindILMBase.cmake b/cmake/FindILMBase.cmake
+deleted file mode 100644
+index c555100..0000000
+--- a/cmake/FindILMBase.cmake
++++ /dev/null
+@@ -1,54 +0,0 @@
+-# Copyright (c) 2009 Sony Pictures Imageworks Inc. et al.
+-#
+-# All rights reserved.
+-#
+-# Redistribution and use in source and binary forms, with or without
+-# modification, are permitted provided that the following conditions
+-# are met:
+-#
+-# Redistributions of source code must retain the above copyright
+-# notice, this list of conditions and the following disclaimer.
+-# Redistributions in binary form must reproduce the above copyright
+-# notice, this list of conditions and the following disclaimer in the
+-# documentation and/or other materials provided with the
+-# distribution. Neither the name of Sony Pictures Imageworks nor the
+-# names of its contributors may be used to endorse or promote
+-# products derived from this software without specific prior written
+-# permission.
+-#
+-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+-# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+-# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+-# FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+-# COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+-# INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+-# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+-# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+-# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+-# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+-# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
+-# OF THE POSSIBILITY OF SUCH DAMAGE.
+-
+-# Author : Nicholas Yue yue.nicholas@gmail.com
+-
+-# This module will define the following variables:
+-# ILMBASE_INCLUDE_DIRS - Location of the ilmbase includes
+-# ILMBASE_LIBRARIES - [TODO] Required libraries for all requested bindings
+-# ILMBASE_FOUND - true if ILMBASE was found on the system
+-# ILMBASE_LIBRARY_DIRS - the full set of library directories
+-
+-FIND_PATH ( Ilmbase_Base_Dir include/OpenEXR/IlmBaseConfig.h
+- ENV ILMBASE_ROOT
+- )
+-
+-IF ( Ilmbase_Base_Dir )
+-
+- SET ( ILMBASE_INCLUDE_DIRS
+- ${Ilmbase_Base_Dir}/include
+- ${Ilmbase_Base_Dir}/include/OpenEXR
+- CACHE STRING "ILMBase include directories")
+- SET ( ILMBASE_LIBRARY_DIRS ${Ilmbase_Base_Dir}/lib
+- CACHE STRING "ILMBase library directories")
+- SET ( ILMBASE_FOUND TRUE )
+-
+-ENDIF ( Ilmbase_Base_Dir )
+--
+2.14.1
+
diff --git a/media-libs/Field3D/files/Field3D-1.7.2-openexr-fixes.patch b/media-libs/Field3D/files/Field3D-1.7.2-openexr-fixes.patch
deleted file mode 100644
index 41ab1ccf2945..000000000000
--- a/media-libs/Field3D/files/Field3D-1.7.2-openexr-fixes.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff -purN a/cmake/FindILMBase.cmake b/cmake/FindILMBase.cmake
---- a/cmake/FindILMBase.cmake 2016-06-19 05:56:00.000000000 +0100
-+++ b/cmake/FindILMBase.cmake 2017-03-02 11:44:35.449043588 +0000
-@@ -37,12 +37,17 @@
- # ILMBASE_FOUND - true if ILMBASE was found on the system
- # ILMBASE_LIBRARY_DIRS - the full set of library directories
-
-+find_package(PkgConfig QUIET)
-+if(PKG_CONFIG_FOUND)
-+ pkg_check_modules(PC_ILMBASE QUIET IlmBase)
-+endif()
-+
- FIND_PATH ( Ilmbase_Base_Dir include/OpenEXR/IlmBaseConfig.h
- ENV ILMBASE_ROOT
- )
-
- IF ( Ilmbase_Base_Dir )
--
-+ SET ( IlmBase_VERSION ${PC_ILMBASE_VERSION} )
- SET ( ILMBASE_INCLUDE_DIRS
- ${Ilmbase_Base_Dir}/include
- ${Ilmbase_Base_Dir}/include/OpenEXR
-diff -purN a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2016-06-19 05:56:00.000000000 +0100
-+++ b/CMakeLists.txt 2017-03-02 11:44:37.029035041 +0000
-@@ -146,8 +146,11 @@ IF ( CMAKE_HOST_UNIX )
- LIST ( APPEND Field3D_Libraries_Shared
- ${MPI_LIBRARIES} )
- ENDIF ( MPI_FOUND )
-+ # handle new library names for 2.0.0
-+ STRING ( REPLACE "." "_" _IlmBase_VERSION ${IlmBase_VERSION} )
-+ STRING ( SUBSTRING ${_IlmBase_VERSION} 0 3 _IlmBase_VERSION )
- LIST ( APPEND Field3D_Libraries_Shared
-- Iex Half IlmThread Imath
-+ Iex-${_IlmBase_VERSION} Half IlmThread-${_IlmBase_VERSION} Imath-${_IlmBase_VERSION}
- pthread dl z )
- SET ( Field3D_DSO_Libraries ${Field3D_Libraries_Shared} )
- SET ( Field3D_BIN_Libraries Field3D ${Field3D_Libraries_Shared}