summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Konno <joe.konno@intel.com>2015-11-19 15:38:57 -0800
committerJoe Konno <joe.konno@intel.com>2015-11-25 07:55:22 -0800
commitc6d19a6e27546c7a7347e4f3ed43574deb056490 (patch)
tree7d14c565d26826a7abeb55d108ab500925f82677 /media-libs/alsa-lib/alsa-lib-1.1.0.ebuild
parentapp-emulation/docker-compose: move enum34 dependence (diff)
downloadgentoo-c6d19a6e27546c7a7347e4f3ed43574deb056490.tar.gz
gentoo-c6d19a6e27546c7a7347e4f3ed43574deb056490.tar.bz2
gentoo-c6d19a6e27546c7a7347e4f3ed43574deb056490.zip
media-libs/alsa-lib: version bump to 1.1.0
Bump to version 1.1.0. The cross-compile patch for 1.0.29 does not appear to be needed, so not carrying it forward for 1.1.0. Mask all architectures until deemed 'stable' by gentoo-sound team. TODO: Version 1.1.0 does introduce the DSP Topology API. This is enabled by default, though there is a configure flag to disable it. There are kernel configuration and ABI version considerations to account for in any future "topology" USE flag handlers-- I haven't sufficient expertise to "do it right" at this time, or I would do so. Rudimentary bench-testing performed on amd64 architecture. ALSA Project Release notes at: http://www.alsa-project.org/main/index.php/Changes_v1.0.29_v1.1.0 Package-Manager: Portage 2.2.20.1 v2: vapier: restored line 37, '# https://bugs.gentoo.org/509886'; rebased on 6d4b41d7904e ("app-emulation/docker-compose: move enum34 dependence") Signed-off-by: Joe Konno <joe.konno@intel.com>
Diffstat (limited to 'media-libs/alsa-lib/alsa-lib-1.1.0.ebuild')
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.1.0.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/media-libs/alsa-lib/alsa-lib-1.1.0.ebuild b/media-libs/alsa-lib/alsa-lib-1.1.0.ebuild
new file mode 100644
index 000000000000..8189fca548c0
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.1.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# no support for python3_2 or above yet wrt #471326
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils multilib multilib-minimal python-single-r1
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="alisp debug doc elibc_uclibc python"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-soundlibs-20130224-r1
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ find . -name Makefile.am -exec sed -i -e '/CFLAGS/s:-g -O2::' {} + || die
+ # https://bugs.gentoo.org/509886
+ use elibc_uclibc && { sed -i -e 's:oldapi queue_timer:queue_timer:' test/Makefile.am || die; }
+ epatch_user
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf
+ # enable Python only on final ABI
+ if multilib_is_native_abi; then
+ myconf="$(use_enable python)"
+ else
+ myconf="--disable-python"
+ fi
+ use elibc_uclibc && myconf+=" --without-versioned"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-maintainer-mode \
+ --enable-shared \
+ --disable-resmgr \
+ --enable-rawmidi \
+ --enable-seq \
+ --enable-aload \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ ${myconf}
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use doc; then
+ emake doc
+ fgrep -Zrl "${S}" doc/doxygen/html | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ if multilib_is_native_abi && use doc; then
+ dohtml -r doc/doxygen/html/.
+ fi
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ find "${ED}"/usr/$(get_libdir)/alsa-lib -name '*.a' -exec rm -f {} +
+ dodoc ChangeLog doc/asoundrc.txt NOTES TODO
+}