summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdel KARA SLIMANE <adel.ks@zegrapher.com>2024-03-23 17:41:07 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-04-26 09:55:02 +0300
commit78873b77ad475f26d05e429fb589e42b1097ff26 (patch)
tree4e9f507a111c7a137b901bef5a522e5073c7e2b3 /media-libs/amf-headers/amf-headers-1.4.33.ebuild
parentmedia-video/amdgpu-pro-amf: drop versions (diff)
downloadgentoo-78873b77ad475f26d05e429fb589e42b1097ff26.tar.gz
gentoo-78873b77ad475f26d05e429fb589e42b1097ff26.tar.bz2
gentoo-78873b77ad475f26d05e429fb589e42b1097ff26.zip
media-libs/amf-headers: add 1.4.33
Signed-off-by: Adel KARA SLIMANE <adel.ks@zegrapher.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/amf-headers/amf-headers-1.4.33.ebuild')
-rw-r--r--media-libs/amf-headers/amf-headers-1.4.33.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/amf-headers/amf-headers-1.4.33.ebuild b/media-libs/amf-headers/amf-headers-1.4.33.ebuild
new file mode 100644
index 000000000000..44e1d134e11d
--- /dev/null
+++ b/media-libs/amf-headers/amf-headers-1.4.33.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/GPUOpen-LibrariesAndSDKs/AMF"
+else
+ SRC_URI="https://github.com/GPUOpen-LibrariesAndSDKs/AMF/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+DESCRIPTION="The Advanced Media Framework (AMF) SDK"
+HOMEPAGE="https://github.com/GPUOpen-LibrariesAndSDKs/AMF"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+S="${WORKDIR}/AMF-${PV}"
+
+src_unpack() {
+ default
+
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ fi
+}
+
+src_install() {
+ insinto "/usr/include/AMF"
+ doins -r "${S}/amf/public/include/"*
+}