summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-04-28 08:06:12 +0200
committerSam James <sam@gentoo.org>2022-04-29 03:22:31 +0100
commit3c7abed13a49d96d90fdeda81bba828271cace87 (patch)
treef99fce74d41e9599f0c03a2c4aa6ba7061d9182f /media-libs/assimp/assimp-5.2.3.ebuild
parentvirtual/perl-Scalar-List-Utils: keyword 1.550.0-r1 for ~loong (diff)
downloadgentoo-3c7abed13a49d96d90fdeda81bba828271cace87.tar.gz
gentoo-3c7abed13a49d96d90fdeda81bba828271cace87.tar.bz2
gentoo-3c7abed13a49d96d90fdeda81bba828271cace87.zip
media-libs/assimp: build with gcc-12
Fix an -Werror=array-bounds issue with gcc-12, by patching out the global -Werror flag used by upstream. Drop failing tests for x86_32. Closes: https://bugs.gentoo.org/840616 Closes: https://bugs.gentoo.org/840767 Bug: https://github.com/assimp/assimp/issues/4438 Bug: https://github.com/assimp/assimp/issues/4433 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/25234 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/assimp/assimp-5.2.3.ebuild')
-rw-r--r--media-libs/assimp/assimp-5.2.3.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/media-libs/assimp/assimp-5.2.3.ebuild b/media-libs/assimp/assimp-5.2.3.ebuild
index ba654ddd393f..451858172fc2 100644
--- a/media-libs/assimp/assimp-5.2.3.ebuild
+++ b/media-libs/assimp/assimp-5.2.3.ebuild
@@ -32,11 +32,20 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-5.2.2-fix-usage-of-incompatible-minizip-data-structure.patch
+ "${FILESDIR}"/${P}-drop-Werror-gcc-option.patch
"${FILESDIR}"/${PN}-5.2.2-disable-failing-tests.patch
)
DOCS=( CodeConventions.md Readme.md )
+src_prepare() {
+ if use abi_x86_32; then
+ eapply "${FILESDIR}"/${P}-drop-failing-tests-for-abi_x86_32.patch
+ fi
+
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DASSIMP_ASAN=OFF