summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2023-12-15 17:50:01 +0100
committerSam James <sam@gentoo.org>2024-01-20 12:26:30 +0000
commit054f5ce87ab5e96a7224e2e396f897472d0d8f62 (patch)
tree14e8d80ec44db3712d83045991f821bad2fdbc4c /media-libs/assimp/files/assimp-5.2.5-gtest.patch
parentsys-kernel/gentoo-sources: add 6.1.74 (diff)
downloadgentoo-054f5ce87ab5e96a7224e2e396f897472d0d8f62.tar.gz
gentoo-054f5ce87ab5e96a7224e2e396f897472d0d8f62.tar.bz2
gentoo-054f5ce87ab5e96a7224e2e396f897472d0d8f62.zip
media-libs/assimp: add 5.2.5-r2, add 5.3.1
Rework tests to make use of gtest via ctest. Some tests generate random input data which might fail on fma-enabled CPUs due to smaller rounding errors on fused operations, so we repeat those tests until they succeed. Closes: https://bugs.gentoo.org/908403 Closes: https://bugs.gentoo.org/910362 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34346 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/assimp/files/assimp-5.2.5-gtest.patch')
-rw-r--r--media-libs/assimp/files/assimp-5.2.5-gtest.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/assimp/files/assimp-5.2.5-gtest.patch b/media-libs/assimp/files/assimp-5.2.5-gtest.patch
new file mode 100644
index 000000000000..9441141337ac
--- /dev/null
+++ b/media-libs/assimp/files/assimp-5.2.5-gtest.patch
@@ -0,0 +1,30 @@
+diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
+index afe4874..5a87cc2 100644
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -191,7 +191,6 @@ SET( POST_PROCESSES
+ unit/utRemoveComments.cpp
+ unit/utRemoveComponent.cpp
+ unit/utVertexTriangleAdjacency.cpp
+- unit/utJoinVertices.cpp
+ unit/utSplitLargeMeshes.cpp
+ unit/utFindDegenerates.cpp
+ unit/utFindInvalidData.cpp
+@@ -281,4 +281,6 @@ target_link_libraries( unit assimp ${platform_libs} )
+
+ add_subdirectory(headercheck)
+
+-add_test( unittests unit )
++get_target_property(unit_SOURCES unit SOURCES)
++find_package(GTest REQUIRED)
++gtest_add_tests(TARGET unit ${unit_SOURCES})
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -725,6 +725,7 @@ IF ( ASSIMP_BUILD_SAMPLES )
+ ENDIF ()
+
+ IF ( ASSIMP_BUILD_TESTS )
++ enable_testing()
+ ADD_SUBDIRECTORY( test/ )
+ ENDIF ()
+