summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/babl/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/babl/files')
-rw-r--r--media-libs/babl/files/babl-0.1.10-clang.patch50
-rw-r--r--media-libs/babl/files/babl-0.1.10-g-ir-compiler-crash.patch12
-rw-r--r--media-libs/babl/files/babl-0.1.10-introspection.patch25
3 files changed, 87 insertions, 0 deletions
diff --git a/media-libs/babl/files/babl-0.1.10-clang.patch b/media-libs/babl/files/babl-0.1.10-clang.patch
new file mode 100644
index 000000000000..68e89d30d71d
--- /dev/null
+++ b/media-libs/babl/files/babl-0.1.10-clang.patch
@@ -0,0 +1,50 @@
+From 16492300a39e75e1015a0ab33e22b1e3f605c5ce Mon Sep 17 00:00:00 2001
+From: Michael Muré <batolettre@gmail.com>
+Date: Tue, 22 May 2012 03:48:44 +0000
+Subject: sse-fixups: use more portable functions to help compile with clang
+
+Original patch found here
+http://www.freebsd.org/cgi/cvsweb.cgi/ports/x11/babl/files/patch-sse-fixups.c?rev=1.1;content-type=text%2Fplain
+
+CVS tags: RELEASE_8_3_0, HEAD
+
+Fix the build with clang.
+
+PR: ports/163518
+Submitted by: Jan Beich <jbeich@tormail.net>
+Feature safe: yes
+---
+(limited to 'extensions/sse-fixups.c')
+
+diff --git a/extensions/sse-fixups.c b/extensions/sse-fixups.c
+index fdcc06f..95f1cc8 100644
+--- a/extensions/sse-fixups.c
++++ b/extensions/sse-fixups.c
+@@ -23,6 +23,8 @@
+
+ #if defined(__GNUC__) && (__GNUC__ >= 4) && defined(USE_SSE) && defined(USE_MMX)
+
++#include <xmmintrin.h>
++
+ #include <stdint.h>
+ #include <stdlib.h>
+
+@@ -40,11 +42,11 @@ typedef int g2int __attribute__ ((vector_size (2*sizeof(int))));
+ #define g4float_zero g4float_all(0.0)
+ #define g4float_ff g4float_all(255.0)
+
+-#define g4float_max(a,b) __builtin_ia32_maxps(a, b)
+-#define g4float_min(a,b) __builtin_ia32_minps(a, b)
+-#define g4float_cvt2pi(a) __builtin_ia32_cvtps2pi(a)
+-#define g4float_movhl(a,b) __builtin_ia32_movhlps(a, b)
+-#define g4float_emms __builtin_ia32_emms
++#define g4float_max(a,b) _mm_max_ps(a, b)
++#define g4float_min(a,b) _mm_min_ps(a, b)
++#define g4float_cvt2pi(a) _mm_cvtps_pi32(a)
++#define g4float_movhl(a,b) _mm_movehl_ps(a, b)
++#define g4float_emms _mm_empty
+
+
+ static INLINE long
+--
+cgit v0.9.0.2
diff --git a/media-libs/babl/files/babl-0.1.10-g-ir-compiler-crash.patch b/media-libs/babl/files/babl-0.1.10-g-ir-compiler-crash.patch
new file mode 100644
index 000000000000..4b6cf919a849
--- /dev/null
+++ b/media-libs/babl/files/babl-0.1.10-g-ir-compiler-crash.patch
@@ -0,0 +1,12 @@
+Index: babl-0.1.10/babl/Makefile.am
+===================================================================
+--- babl-0.1.10.orig/babl/Makefile.am
++++ babl-0.1.10/babl/Makefile.am
+@@ -95,6 +95,7 @@ INTROSPECTION_COMPILER_ARGS = --included
+ if HAVE_INTROSPECTION
+ Babl-$(BABL_API_VERSION).gir: $(G_IR_SCANNER) $(library_include_HEADERS) $(c_sources) $(srcdir)/Makefile.am libbabl-@BABL_API_VERSION@.la
+ $(INTROSPECTION_SCANNER) -v --namespace Babl --nsversion=$(BABL_API_VERSION) \
++ --identifier-prefix= --symbol-prefix=babl \
+ --add-include-path=$(srcdir) --add-include-path=. \
+ --library=$(builddir)/libbabl-$(BABL_API_VERSION).la \
+ --libtool="$(LIBTOOL)" \
diff --git a/media-libs/babl/files/babl-0.1.10-introspection.patch b/media-libs/babl/files/babl-0.1.10-introspection.patch
new file mode 100644
index 000000000000..f9b92698689d
--- /dev/null
+++ b/media-libs/babl/files/babl-0.1.10-introspection.patch
@@ -0,0 +1,25 @@
+From c024c89f95de4a8fa95ba96790dac61768d11a17 Mon Sep 17 00:00:00 2001
+From: Dominique Leuenberger <dimstar@opensuse.org>
+Date: Tue, 10 Jan 2012 16:32:50 +0000
+Subject: gobject-introspection: fix build of the .gir and .typelib files.
+
+---
+diff --git a/babl/Makefile.am b/babl/Makefile.am
+index cefab57..03115a3 100644
+--- a/babl/Makefile.am
++++ b/babl/Makefile.am
+@@ -93,10 +93,10 @@ INTROSPECTION_SCANNER_ARGS = --add-include-path=$(srcdir)
+ INTROSPECTION_COMPILER_ARGS = --includedir=$(srcdir)
+
+ if HAVE_INTROSPECTION
+-Babl-$(BABL_API_VERSION).gir: $(G_IR_SCANNER) $(library_include_HEADERS) $(c_sources) $(srcdir)/Makefile.am
++Babl-$(BABL_API_VERSION).gir: $(G_IR_SCANNER) $(library_include_HEADERS) $(c_sources) $(srcdir)/Makefile.am libbabl-@BABL_API_VERSION@.la
+ $(INTROSPECTION_SCANNER) -v --namespace Babl --nsversion=$(BABL_API_VERSION) \
+ --add-include-path=$(srcdir) --add-include-path=. \
+- --library=babl-$(BABL_API_VERSION) \
++ --library=$(builddir)/libbabl-$(BABL_API_VERSION).la \
+ --libtool="$(LIBTOOL)" \
+ --output $@ \
+ -DBABL_IS_BEING_COMPILED \
+--
+cgit v0.9.1