summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-11-25 01:22:37 +0100
committerSebastian Pipping <sping@gentoo.org>2018-11-25 01:23:25 +0100
commit6d737c78be0b9df255cff0859ebd796c4425f971 (patch)
tree81edc7345b8e7a68a66654958133eb2e680c76b1 /media-libs/babl
parentsci-chemistry/votca-csg: 1.4.1 doesn't support gmx-2019_beta (diff)
downloadgentoo-6d737c78be0b9df255cff0859ebd796c4425f971.tar.gz
gentoo-6d737c78be0b9df255cff0859ebd796c4425f971.tar.bz2
gentoo-6d737c78be0b9df255cff0859ebd796c4425f971.zip
media-libs/babl: 0.1.60
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'media-libs/babl')
-rw-r--r--media-libs/babl/Manifest1
-rw-r--r--media-libs/babl/babl-0.1.60.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/babl/Manifest b/media-libs/babl/Manifest
index 7d4b66af7624..48f8547f9082 100644
--- a/media-libs/babl/Manifest
+++ b/media-libs/babl/Manifest
@@ -3,3 +3,4 @@ DIST babl-0.1.18.tar.bz2 734225 BLAKE2B 8fc7f0c25adbde4c88fef6ef104de232f5dd074c
DIST babl-0.1.38.tar.bz2 653047 BLAKE2B 8bc43a7e0b7265f72122743ff4b3e25825e4bbe6797a6e077de16d47239a67cc8fcb93253f54de31012cfb1622cafed2c220cba5cb3cdd9eb1599e5d11b4000f SHA512 4b55b666170322adad4b4624c98110d7a34c496f7aadb22a53c09d1ce5ae518122c2105fd2cb2a057e752fe1540beb703f8192e48e7c43601342a75db2bfdca0
DIST babl-0.1.56.tar.bz2 673080 BLAKE2B a172819342e6982249734d2e5a0014bc9feaf882788c50c72494adac7160e9cca4b8d45411c110217b8bd8642fe46689295801f1207e54de1219be5e13a475b0 SHA512 e3d6192126df136537ce13b2858a7ec078251093762052bb3edd826a26ab36fee73375ee854bdf423f22fc30f23bcafb3ae46e986ed6555f3ef0809b12c612ba
DIST babl-0.1.58.tar.bz2 686407 BLAKE2B 89e93f9152adddd5761728e0234e0139b8e7a4611fd0b082998f34bfca6cfc155d35e3d9b66d777022948d6b46e8d6e12af739d43138139b361c63879f39f1da SHA512 4747e9432072ab786f096f18fabe307587f307369ca89ec7ece2ae8db59ea8f618a67c6c9ed93a8f21533bd91e00db05653b37b923dfee074d7c4381452324ce
+DIST babl-0.1.60.tar.bz2 685707 BLAKE2B dccbbb6974160377eb70fa32dad998ceeed6d065ba87a34c11d38e4bd2ea6a4c359f107bfe4afc0ab637fea99377d83c4669519a61fbc9e221a842d1d5375870 SHA512 a65533b4527c4334c7ab14fb16be41e3e2e93f51bbeb24dd427fa9263e25fa8ad83337b73a805bebc2414fb57bccceaa681f89ce5c5187bd0a03703bf07cccc2
diff --git a/media-libs/babl/babl-0.1.60.ebuild b/media-libs/babl/babl-0.1.60.ebuild
new file mode 100644
index 000000000000..8d6d747f60ae
--- /dev/null
+++ b/media-libs/babl/babl-0.1.60.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune
+
+if [[ ${PV} == *9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/babl.git"
+ SRC_URI=""
+else
+ inherit autotools
+ SRC_URI="http://ftp.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A dynamic, any to any, pixel format conversion library"
+HOMEPAGE="http://www.gegl.org/babl/"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="altivec cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_sse4_1 cpu_flags_x86_mmx cpu_flags_x86_f16c"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Automagic rsvg support is just for website generation we do not call,
+ # so we don't need to fix it
+ # w3m is used for dist target thus no issue for us that it is automagically
+ # detected
+ econf \
+ --disable-docs \
+ --disable-static \
+ --disable-maintainer-mode \
+ $(use_enable altivec) \
+ $(use_enable cpu_flags_x86_f16c f16c) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable cpu_flags_x86_sse3 sse3) \
+ $(use_enable cpu_flags_x86_sse4_1 sse4_1)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}