summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/clutter-gst/clutter-gst-2.0.16.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/clutter-gst/clutter-gst-2.0.16.ebuild')
-rw-r--r--media-libs/clutter-gst/clutter-gst-2.0.16.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/media-libs/clutter-gst/clutter-gst-2.0.16.ebuild b/media-libs/clutter-gst/clutter-gst-2.0.16.ebuild
new file mode 100644
index 000000000000..2fbe050ed181
--- /dev/null
+++ b/media-libs/clutter-gst/clutter-gst-2.0.16.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1
+
+HOMEPAGE="http://www.clutter-project.org/"
+DESCRIPTION="GStreamer integration library for Clutter"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="examples +introspection"
+
+# FIXME: Support for gstreamer-basevideo-0.10 (HW decoder support) is automagic
+COMMON_DEPEND="
+ >=dev-libs/glib-2.20:2
+ >=media-libs/clutter-1.6.0:1.0=[introspection?]
+ >=media-libs/cogl-1.10:1.0=[introspection?]
+ >=media-libs/gstreamer-1.2.0:1.0[introspection?]
+ >=media-libs/gst-plugins-bad-1.2.0:1.0
+ >=media-libs/gst-plugins-base-1.2.0:1.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.8 )
+"
+# uses goom from gst-plugins-good
+RDEPEND="${COMMON_DEPEND}
+ >=media-libs/gst-plugins-good-1.2.0:1.0
+"
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/gtk-doc-am-1.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Make doc parallel installable
+ cd "${S}"/doc/reference
+ sed -e "s/\(DOC_MODULE.*=\).*/\1${PN}-${SLOT}/" \
+ -e "s/\(DOC_MAIN_SGML_FILE.*=\).*/\1${PN}-docs-${SLOT}.sgml/" \
+ -i Makefile.am Makefile.in || die
+ sed -e "s/\(<book.*name=\"\)clutter-gst/\1${PN}-${SLOT}/" \
+ -i html/clutter-gst.devhelp2 || die
+ mv clutter-gst-docs{,-${SLOT}}.sgml || die
+ mv clutter-gst-overrides{,-${SLOT}}.txt || die
+ mv clutter-gst-sections{,-${SLOT}}.txt || die
+ mv clutter-gst{,-${SLOT}}.types || die
+ mv html/clutter-gst{,-${SLOT}}.devhelp2
+
+ cd "${S}"
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-maintainer-flags \
+ $(use_enable introspection)
+}
+
+src_compile() {
+ # Clutter tries to access dri without userpriv, upstream bug #661873
+ # Massive failure of a hack, see bug 360219, bug 360073, bug 363917
+ unset DISPLAY
+ gnome2_src_compile
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/"${PF}"/examples
+ doins examples/{*.c,*.png,README}
+ fi
+}