summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2022-08-07 22:01:44 +0800
committerSam James <sam@gentoo.org>2022-08-16 03:40:32 +0100
commit434d444d892303b3395af73118547ea45d18985e (patch)
treedddacbbf1a0ce45749d2be31e979a50ff4454827 /media-libs/codec2/codec2-1.0.5.ebuild
parentsys-apps/file: fix 9999 install (README rename) (diff)
downloadgentoo-434d444d892303b3395af73118547ea45d18985e.tar.gz
gentoo-434d444d892303b3395af73118547ea45d18985e.tar.bz2
gentoo-434d444d892303b3395af73118547ea45d18985e.zip
media-libs/codec2: add 1.0.5
Signed-off-by: Huang Rui <vowstar@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/codec2/codec2-1.0.5.ebuild')
-rw-r--r--media-libs/codec2/codec2-1.0.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/codec2/codec2-1.0.5.ebuild b/media-libs/codec2/codec2-1.0.5.ebuild
new file mode 100644
index 000000000000..fdd5f6ec18cf
--- /dev/null
+++ b/media-libs/codec2/codec2-1.0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Low bit rate speech codec"
+HOMEPAGE="https://freedv.org/ https://www.rowetel.com/?page_id=452 https://github.com/drowe67/codec2"
+SRC_URI="https://github.com/drowe67/codec2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples test"
+
+# Not yet passing, but infrastructure added to run
+# Needs Octave dependencies like "signal"?
+# https://github.com/drowe67/codec2/commit/9a129f1b3ad12ecbf3df7f4460f496ee11e49c08#diff-b335630551682c19a781afebcf4d07bf978fb1f8ac04c6bf87428ed5106870f5R155
+RESTRICT="test"
+
+#BDEPEND="test? ( sci-mathematics/octave )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUNITTEST=$(usex test)
+ -DINSTALL_EXAMPLES=$(usex examples)
+ )
+
+ cmake_src_configure
+}