summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancisco Javier FĂ©lix <web@inode64.com>2021-10-18 08:57:28 +0200
committerSam James <sam@gentoo.org>2021-10-31 03:39:32 +0000
commit647a8643d2941d4f20a6cb2b4799fc35bbc26c36 (patch)
treeea25ce1a5a1af393d382f5c40853995c1f38fc5a /media-libs/dav1d/dav1d-0.9.1.ebuild
parentnet-misc/stuntman: 1.2.16 (diff)
downloadgentoo-647a8643d2941d4f20a6cb2b4799fc35bbc26c36.tar.gz
gentoo-647a8643d2941d4f20a6cb2b4799fc35bbc26c36.tar.bz2
gentoo-647a8643d2941d4f20a6cb2b4799fc35bbc26c36.zip
media-libs/dav1d: fix build, support xxhash
* Require minimum nasm 2.15.05 * Disable test by default * Fix build, see bug https://code.videolan.org/videolan/dav1d/-/issues/370 and patch https://code.videolan.org/videolan/dav1d/-/commit/c6a08b3aa1ee99dade53e5e32033bc1d14455a22 the same problem with versions of gcc 10.3.0 and gcc 11.2.0, from dav1d 0.8.2 to 0.9.2. Closes: https://bugs.gentoo.org/738726 Closes: https://bugs.gentoo.org/791544 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: INODE64 <ffelix@inode64.com> Closes: https://github.com/gentoo/gentoo/pull/22621 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/dav1d/dav1d-0.9.1.ebuild')
-rw-r--r--media-libs/dav1d/dav1d-0.9.1.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/media-libs/dav1d/dav1d-0.9.1.ebuild b/media-libs/dav1d/dav1d-0.9.1.ebuild
index 7dedeea1b795..f7ae3e3273bf 100644
--- a/media-libs/dav1d/dav1d-0.9.1.ebuild
+++ b/media-libs/dav1d/dav1d-0.9.1.ebuild
@@ -19,15 +19,19 @@ HOMEPAGE="https://code.videolan.org/videolan/dav1d"
LICENSE="BSD-2"
SLOT="0/5"
-IUSE="+8bit +10bit +asm"
+IUSE="+8bit +10bit +asm test xxhash"
+RESTRICT="!test? ( test )"
-ASM_DEPEND=">=dev-lang/nasm-2.14.02"
+ASM_DEPEND=">=dev-lang/nasm-2.15.05"
BDEPEND="asm? (
abi_x86_32? ( ${ASM_DEPEND} )
abi_x86_64? ( ${ASM_DEPEND} )
- )"
+ )
+ xxhash? ( dev-libs/xxhash )
+ "
DOCS=( README.md doc/PATENTS THANKS.md )
+PATCHES=( "${FILESDIR}"/build-avoid-meson-s-symbols_have_underscore_prefix.patch )
multilib_src_configure() {
local -a bits=()
@@ -44,6 +48,8 @@ multilib_src_configure() {
local emesonargs=(
-D bitdepths=$(IFS=,; echo "${bits[*]}")
-D enable_asm=${enable_asm}
+ -D enable_tests=$(usex test true false)
+ -D xxhash_muxer=$(usex xxhash enabled disabled)
)
meson_src_configure
}