summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-06 13:41:40 +0100
committerSam James <sam@gentoo.org>2021-08-06 13:57:56 +0100
commit6b0a84d86058016bdee28c240e79582a8bd31f16 (patch)
tree1f51ac21083186e02528f7d7808a9aef9bf2760a /media-libs/dav1d
parentgames-sports/speed-dreams: remove faq.html (diff)
downloadgentoo-6b0a84d86058016bdee28c240e79582a8bd31f16.tar.gz
gentoo-6b0a84d86058016bdee28c240e79582a8bd31f16.tar.bz2
gentoo-6b0a84d86058016bdee28c240e79582a8bd31f16.zip
media-libs/dav1d: add 0.9.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/dav1d')
-rw-r--r--media-libs/dav1d/Manifest1
-rw-r--r--media-libs/dav1d/dav1d-0.9.1.ebuild55
-rw-r--r--media-libs/dav1d/dav1d-9999.ebuild2
3 files changed, 57 insertions, 1 deletions
diff --git a/media-libs/dav1d/Manifest b/media-libs/dav1d/Manifest
index 347317dbde00..8c138006ad40 100644
--- a/media-libs/dav1d/Manifest
+++ b/media-libs/dav1d/Manifest
@@ -1,3 +1,4 @@
DIST dav1d-0.8.0.tar.bz2 668627 BLAKE2B 6f45c6b0011acb74bb26fa201e667b16dbf8b691a2bc5d2043517381ca58132fa29ee828841609762737ac8637948b2bd4bac9e2c1d2ca23b1d3ad23f5883875 SHA512 906481ce5b9ce99cef2723c4c2466ba762095b9f88caccd42dcabfd4800964d7cd142736de1bf2ef25b631ee01eb26f7f1ac1754fc161b8fb7192e104df10e28
DIST dav1d-0.8.2.tar.bz2 695931 BLAKE2B cfe7667e583e05f8fd84b226a26ea23a901336fd8cf62900b47cd6b3bf92f8fe58d14224d1e063cc3bf7abdb17da437d291dc3f604cb68e99fc0615619f76880 SHA512 73335594950b08596356a1950213abf57c6d48060da37149e700565f9689ca82b7427e320040bf43b2e97eff7b6da7116a6aca77cb717f7ce140039ebdae5595
DIST dav1d-0.9.0.tar.bz2 771739 BLAKE2B 9cf24b142a1148200766a1a20010ff14d1baec507a7ecb477117826784b668178ba753049abf316aacbe1b957340c157f960f748ab8e6f74caf567edba2be3a9 SHA512 cfbfa4cb4508e1b975d7247bf0fa09d3b7adfd224adcf181153365677237b98a6d53b0b7bb91055a26e5668d58b3dcda5f675f68aceb1b020d14b53c4488575e
+DIST dav1d-0.9.1.tar.bz2 810641 BLAKE2B 6ad40f6a339a71bc2bf79c508bc7a8a58cda98c6814981d252a3a40ae8df1cc5ad120c42fc881cb560c84e01186ca3daa09cbb5f6152d7da475d9479aa306f2c SHA512 b688f4743106ceed5f450978a9c265391c0ee906dd5adb8632e563378b316ffb3a7098fb6ea2ef4b160ca880fc03c16e3e3b9d8aa3c90ee7341dd0cbfccecc46
diff --git a/media-libs/dav1d/dav1d-0.9.1.ebuild b/media-libs/dav1d/dav1d-0.9.1.ebuild
new file mode 100644
index 000000000000..850f1843db9a
--- /dev/null
+++ b/media-libs/dav1d/dav1d-0.9.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+SCM=""
+if [[ "${PV}" == "9999" ]]; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://code.videolan.org/videolan/dav1d"
+else
+ SRC_URI="https://code.videolan.org/videolan/dav1d/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+inherit ${SCM} meson-multilib
+
+DESCRIPTION="dav1d is an AV1 Decoder :)"
+HOMEPAGE="https://code.videolan.org/videolan/dav1d"
+
+LICENSE="BSD-2"
+SLOT="0/5"
+IUSE="+8bit +10bit +asm"
+
+ASM_DEPEND=">=dev-lang/nasm-2.14.02"
+BDEPEND="asm? (
+ abi_x86_32? ( ${ASM_DEPEND} )
+ abi_x86_64? ( ${ASM_DEPEND} )
+ )"
+
+DOCS=( README.md doc/PATENTS THANKS.md )
+
+multilib_src_configure() {
+ local -a bits=()
+ use 8bit && bits+=( 8 )
+ use 10bit && bits+=( 16 )
+
+ local enable_asm
+ if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
+ enable_asm=false
+ else
+ enable_asm=$(usex asm true false)
+ fi
+
+ local emesonargs=(
+ -D bitdepths=$(IFS=,; echo "${bits[*]}")
+ -D enable_asm=${enable_asm}
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi ; then
+ meson_src_test
+ fi
+}
diff --git a/media-libs/dav1d/dav1d-9999.ebuild b/media-libs/dav1d/dav1d-9999.ebuild
index e8fc5114e038..850f1843db9a 100644
--- a/media-libs/dav1d/dav1d-9999.ebuild
+++ b/media-libs/dav1d/dav1d-9999.ebuild
@@ -8,8 +8,8 @@ if [[ "${PV}" == "9999" ]]; then
SCM="git-r3"
EGIT_REPO_URI="https://code.videolan.org/videolan/dav1d"
else
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
SRC_URI="https://code.videolan.org/videolan/dav1d/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
inherit ${SCM} meson-multilib