summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2018-10-01 19:44:24 +0000
committerLuca Barbato <lu_zero@gentoo.org>2018-10-01 21:03:04 +0000
commitaedbcba4f4c0eef97557e9d8068dbeec1e154b54 (patch)
treef9d1d1a6634811507c6395f3cb6fddaf1ddc3eeb /media-libs/dav1d
parentmedia-libs/dav1d: Adding the maintainer (diff)
downloadgentoo-aedbcba4f4c0eef97557e9d8068dbeec1e154b54.tar.gz
gentoo-aedbcba4f4c0eef97557e9d8068dbeec1e154b54.tar.bz2
gentoo-aedbcba4f4c0eef97557e9d8068dbeec1e154b54.zip
media-libs/dav1d: Do not build the x86 assembly on x32
It is not supported by upstream right now. bug #667460 Package-Manager: Portage-2.3.50, Repoman-2.3.10 Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
Diffstat (limited to 'media-libs/dav1d')
-rw-r--r--media-libs/dav1d/dav1d-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/media-libs/dav1d/dav1d-9999.ebuild b/media-libs/dav1d/dav1d-9999.ebuild
index 2f6ff4e339b5..c5eab1165a34 100644
--- a/media-libs/dav1d/dav1d-9999.ebuild
+++ b/media-libs/dav1d/dav1d-9999.ebuild
@@ -36,9 +36,15 @@ multilib_src_configure() {
use 8bit && bits+=( 8 )
use 10bit && bits+=( 10 )
+ if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
+ build_asm=false
+ else
+ build_asm=$(usex asm true false)
+ fi
+
local emesonargs=(
-D bitdepths=$(IFS=,; echo "${bits[*]}")
- -D build_asm=$(usex asm true false)
+ -D build_asm=$build_asm
)
meson_src_configure
}