summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-09-03 11:01:03 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2015-09-03 11:06:05 -0400
commitbbec455c85cfdd85ae529cc407ede34277127c91 (patch)
tree82b0c2efcc5a2f6765670db8d7e325af0b541c12 /media-libs/devil
parentdev-java/easymock: Keyword for ppc+ppc64. Fixes bug 538380. (diff)
downloadgentoo-bbec455c85cfdd85ae529cc407ede34277127c91.tar.gz
gentoo-bbec455c85cfdd85ae529cc407ede34277127c91.tar.bz2
gentoo-bbec455c85cfdd85ae529cc407ede34277127c91.zip
fix building with gcc-5.2 with patch from Sven Eden via bug 552370
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-libs/devil')
-rw-r--r--media-libs/devil/devil-1.7.8-r2.ebuild2
-rw-r--r--media-libs/devil/files/devil-1.7.8-restrict.patch23
2 files changed, 24 insertions, 1 deletions
diff --git a/media-libs/devil/devil-1.7.8-r2.ebuild b/media-libs/devil/devil-1.7.8-r2.ebuild
index 1f03c571c27a..8be02814856a 100644
--- a/media-libs/devil/devil-1.7.8-r2.ebuild
+++ b/media-libs/devil/devil-1.7.8-r2.ebuild
@@ -38,7 +38,7 @@ DEPEND="${RDEPEND}
X? ( x11-proto/xextproto )"
src_prepare() {
- epatch "${FILESDIR}"/${P}-{CVE-2009-3994,libpng14,nvtt-glut,ILUT}.patch
+ epatch "${FILESDIR}"/${P}-{CVE-2009-3994,libpng14,nvtt-glut,ILUT,restrict}.patch
eautoreconf
}
diff --git a/media-libs/devil/files/devil-1.7.8-restrict.patch b/media-libs/devil/files/devil-1.7.8-restrict.patch
new file mode 100644
index 000000000000..d99ccb3a3008
--- /dev/null
+++ b/media-libs/devil/files/devil-1.7.8-restrict.patch
@@ -0,0 +1,23 @@
+Patch from Sven Eden via bug 552370
+https://bugs.gentoo.org/show_bug.cgi?id=552370
+
+--- a/include/IL/il.h 2009-03-08 08:10:08.000000000 +0100
++++ b/include/IL/il.h 2015-09-03 16:22:04.056637044 +0200
+@@ -63,13 +63,13 @@
+ #endif
+ #endif
+
+-#ifdef RESTRICT_KEYWORD
+-#define RESTRICT restrict
+-#define CONST_RESTRICT const restrict
++#if defined(RESTRICT_KEYWORD) && !defined(__cplusplus)
++#define RESTRICT __restrict__
++#define CONST_RESTRICT const __restrict__
+ #else
+ #define RESTRICT
+ #define CONST_RESTRICT const
+-#endif
++#endif // RESTRICT keyword and not C++
+
+ #include <stdio.h>
+