summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-10-09 08:45:20 -0400
committerMike Frysinger <vapier@gentoo.org>2015-10-09 08:50:15 -0400
commit61294e6fb8a2dad82056c57c0067b5c6cad8d48a (patch)
treec8684a48dc11afce7f03fb9abdd8742441142c57 /media-libs/elementary/elementary-1.15.2.ebuild
parentdev-libs/efl: version bump to 1.15.2 #562434 (diff)
downloadgentoo-61294e6fb8a2dad82056c57c0067b5c6cad8d48a.tar.gz
gentoo-61294e6fb8a2dad82056c57c0067b5c6cad8d48a.tar.bz2
gentoo-61294e6fb8a2dad82056c57c0067b5c6cad8d48a.zip
media-libs/elementary: version bump to 1.15.2 #562440
Diffstat (limited to 'media-libs/elementary/elementary-1.15.2.ebuild')
-rw-r--r--media-libs/elementary/elementary-1.15.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-libs/elementary/elementary-1.15.2.ebuild b/media-libs/elementary/elementary-1.15.2.ebuild
new file mode 100644
index 000000000000..7cef5b066732
--- /dev/null
+++ b/media-libs/elementary/elementary-1.15.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_P=${P/_/-}
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_SUB_PROJECT="core"
+ EGIT_URI_APPEND="${PN}"
+else
+ SRC_URI="https://download.enlightenment.org/rel/libs/${PN}/${MY_P}.tar.xz"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Basic widget set, based on EFL for mobile touch-screen devices"
+HOMEPAGE="https://trac.enlightenment.org/e/wiki/Elementary"
+
+LICENSE="LGPL-2.1"
+IUSE="debug examples fbcon quicklaunch sdl wayland X static-libs"
+
+DEPEND=">=dev-libs/efl-${PV}[fbcon?,sdl?,png,wayland?,X?]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ E_ECONF=(
+ $(use_enable debug)
+ $(use_enable doc)
+ --disable-ecore-cocoa
+ --disable-ecore-psl1ght
+ --disable-ecore-win32
+ --disable-elocation
+ --disable-emap
+ --disable-eweather
+ # broken: make[4]: *** No rule to make target 'prefs_example_01.epb', needed by 'all-am'. Stop
+ #$(use_enable examples build-examples)
+ $(use_enable examples install-examples)
+ $(use_enable fbcon ecore-fb)
+ $(use_enable sdl ecore-sdl)
+ $(use_enable wayland ecore-wayland)
+ $(use_enable X ecore-x)
+ $(use_enable quicklaunch quick-launch)
+ )
+
+ enlightenment_src_configure
+}