summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/emfengine
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/emfengine')
-rw-r--r--media-libs/emfengine/Manifest1
-rw-r--r--media-libs/emfengine/emfengine-0.8.ebuild53
-rw-r--r--media-libs/emfengine/files/0.7-config.patch13
-rw-r--r--media-libs/emfengine/files/0.7-header.patch13
-rw-r--r--media-libs/emfengine/files/0.8-example.patch12
-rw-r--r--media-libs/emfengine/metadata.xml8
6 files changed, 100 insertions, 0 deletions
diff --git a/media-libs/emfengine/Manifest b/media-libs/emfengine/Manifest
new file mode 100644
index 000000000000..b9d87ac27609
--- /dev/null
+++ b/media-libs/emfengine/Manifest
@@ -0,0 +1 @@
+DIST EmfEngine-0.8-opensource.zip 37494 SHA256 3d30b94a6a9529ece104d1d5e948acda69287e66580ed6a4be75e476827f16a8 SHA512 70f8c122520b3053032d9ca36a40cdb3ab647a8e51b6570e40c0855fe478e953fec3a66f99c7fd217cf91c963c031efb7cbaeb10f4a8ca7860752799950fc7ba WHIRLPOOL 9e372afdcfad4bda6399b90d91f82f71262554e0897d2ce165f764401415d169a79e0c57bc3efc1d47ed6589792d2b3ff9048671347a6e164a755a335c18c162
diff --git a/media-libs/emfengine/emfengine-0.8.ebuild b/media-libs/emfengine/emfengine-0.8.ebuild
new file mode 100644
index 000000000000..ba805363f0b8
--- /dev/null
+++ b/media-libs/emfengine/emfengine-0.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils qmake-utils
+
+MY_PN="EmfEngine"
+
+DESCRIPTION="Native vector graphics file format on Windows"
+HOMEPAGE="http://soft.proindependent.com/emf/index.html"
+SRC_URI="http://dev.gentoo.org/~jelc/distfiles/${MY_PN}-${PV}-opensource.zip"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ media-libs/libemf
+ media-libs/libpng:0
+ "
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"/${MY_PN}
+
+PATCHES=(
+ "${FILESDIR}/0.7-config.patch"
+ "${FILESDIR}/0.7-header.patch"
+ "${FILESDIR}"/${PV}-example.patch
+ )
+
+src_prepare() {
+ edos2unix EmfEngine.pro
+ epatch ${PATCHES[@]}
+ sed \
+ -e "s:/usr/local/lib/libEMF.a:-lEMF:g" \
+ -e "s:/usr/local/include:${EPREFIX}/usr/include/:g" \
+ -i src/src.pro example/example.pro || die
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ dolib.so libEmfEngine.so*
+ doheader src/*.h*
+}
diff --git a/media-libs/emfengine/files/0.7-config.patch b/media-libs/emfengine/files/0.7-config.patch
new file mode 100644
index 000000000000..709663aa3c8a
--- /dev/null
+++ b/media-libs/emfengine/files/0.7-config.patch
@@ -0,0 +1,13 @@
+diff --git a/config.pri b/config.pri
+index 97854bc..db7e20f 100644
+--- a/config.pri
++++ b/config.pri
+@@ -8,7 +8,7 @@ win32:CONFIG += HAVE_GDI_PLUS
+ #DEFINES += HAVE_ANTIALIASED_TEXT
+
+ # Comment the following line if you want to build EmfEngine statically
+-#CONFIG += EmfEngineDll
++CONFIG += EmfEngineDll
+
+
+
diff --git a/media-libs/emfengine/files/0.7-header.patch b/media-libs/emfengine/files/0.7-header.patch
new file mode 100644
index 000000000000..4d5964fc6806
--- /dev/null
+++ b/media-libs/emfengine/files/0.7-header.patch
@@ -0,0 +1,13 @@
+diff --git a/src/EmfEngine.h b/src/EmfEngine.h
+index 12b1e5b..0573083 100644
+--- a/src/EmfEngine.h
++++ b/src/EmfEngine.h
+@@ -52,7 +52,7 @@
+ using namespace Gdiplus;
+ #else
+ #ifdef Q_WS_X11
+- #include <emf.h>
++ #include <libEMF/emf.h>
+ #endif
+
+ #ifdef Q_WS_MAC
diff --git a/media-libs/emfengine/files/0.8-example.patch b/media-libs/emfengine/files/0.8-example.patch
new file mode 100644
index 000000000000..251419663c0f
--- /dev/null
+++ b/media-libs/emfengine/files/0.8-example.patch
@@ -0,0 +1,12 @@
+diff --git a/EmfEngine.pro b/EmfEngine.pro
+index 4615ffa..032c8b9 100644
+--- a/EmfEngine.pro
++++ b/EmfEngine.pro
+@@ -3,5 +3,4 @@ include( config.pri )
+ TEMPLATE = subdirs
+
+ SUBDIRS = \
+- src \
+- example
+\ No newline at end of file
++ src
diff --git a/media-libs/emfengine/metadata.xml b/media-libs/emfengine/metadata.xml
new file mode 100644
index 000000000000..4bf6dbc6b1ea
--- /dev/null
+++ b/media-libs/emfengine/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>sci@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>