summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-02-24 09:33:27 +0000
committerSam James <sam@gentoo.org>2023-03-11 16:24:07 +0000
commit3022f80e26ac1e4ad8b0af1d95bbe8e10d3197d3 (patch)
treea2b57e5a1739fbfe14bde98c290f67bd45c9c2dd /media-libs/exiftool
parentnet-p2p/kubo: add 0.18.1 (diff)
downloadgentoo-3022f80e26ac1e4ad8b0af1d95bbe8e10d3197d3.tar.gz
gentoo-3022f80e26ac1e4ad8b0af1d95bbe8e10d3197d3.tar.bz2
gentoo-3022f80e26ac1e4ad8b0af1d95bbe8e10d3197d3.zip
media-libs/exiftool: add 12.50
Which is the latest production release with some good bug fixes. Signed-off-by: Michael Vetter <jubalh@iodoru.org> Closes: https://github.com/gentoo/gentoo/pull/29761 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/exiftool')
-rw-r--r--media-libs/exiftool/Manifest1
-rw-r--r--media-libs/exiftool/exiftool-12.50.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/exiftool/Manifest b/media-libs/exiftool/Manifest
index e456c1341eee..d9e313825a5d 100644
--- a/media-libs/exiftool/Manifest
+++ b/media-libs/exiftool/Manifest
@@ -1 +1,2 @@
DIST Image-ExifTool-12.42.tar.gz 5042086 BLAKE2B c518906dfc6c354a6bf834044322727ff0c6787f74c387fb24b2320072bb525fd8b0b55d74cc324ac6e2ad6e75de0f3c552db2f6a1e665ab4b1bed9117916c2b SHA512 f7d3dd98623f44473f67ccf740370fd7704b60274efe1272b5219599dba9fe312afe4107937c6d64c5ee11380914b6e97a5248a2abcf88820822f9947cae0f8f
+DIST Image-ExifTool-12.50.tar.gz 5088286 BLAKE2B bfc0eae786e1443df5f741f5deed339b76b3041ab939c45303775df9ad22d989bbd68b77c9b8f2259c493dd81828b31223e604ef8bb4867c952cfb892a38a9d5 SHA512 d95be3636ed139a41a14183fc31fa2ecb5ea71b570ccdd282b9f0bba84a264b2edff2c42b34ee1114a14b106383d5ab3b67b8e73642e534f4df3fa54082dba85
diff --git a/media-libs/exiftool/exiftool-12.50.ebuild b/media-libs/exiftool/exiftool-12.50.ebuild
new file mode 100644
index 000000000000..94747649065c
--- /dev/null
+++ b/media-libs/exiftool/exiftool-12.50.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Check https://exiftool.org/history.html for whether a release is 'production'
+# Ideally don't bump to non-production at all, but certainly don't stable.
+
+DIST_NAME=Image-ExifTool
+inherit perl-module
+
+DESCRIPTION="Read and write meta information in image, audio and video files"
+HOMEPAGE="https://exiftool.org/ http://exiftool.sourceforge.net"
+SRC_URI="https://exiftool.org/${DIST_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~x64-macos"
+IUSE="doc"
+
+src_install() {
+ perl-module_src_install
+ use doc && dodoc -r html/
+
+ insinto /usr/share/${PN}
+ doins -r fmt_files config_files arg_files
+}