summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-03 03:46:43 +0100
committerSam James <sam@gentoo.org>2022-06-03 04:08:44 +0100
commitbb1fa45feb8a0daad9173f06a2e564ff4be23c8e (patch)
treed6338e584697b137fa7289e7c004deaad7c3f4c6 /media-libs/exiftool
parentapp-admin/ansible-base: readd 2.12.6 (diff)
downloadgentoo-bb1fa45feb8a0daad9173f06a2e564ff4be23c8e.tar.gz
gentoo-bb1fa45feb8a0daad9173f06a2e564ff4be23c8e.tar.bz2
gentoo-bb1fa45feb8a0daad9173f06a2e564ff4be23c8e.zip
media-libs/exiftool: add 12.42
Closes: https://bugs.gentoo.org/832033 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/exiftool')
-rw-r--r--media-libs/exiftool/Manifest1
-rw-r--r--media-libs/exiftool/exiftool-12.42.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/exiftool/Manifest b/media-libs/exiftool/Manifest
index e8357415c74a..6d617b8ca7fe 100644
--- a/media-libs/exiftool/Manifest
+++ b/media-libs/exiftool/Manifest
@@ -1,2 +1,3 @@
DIST Image-ExifTool-12.30.tar.gz 4948601 BLAKE2B 359c06dc5d4f71e186d7a265488cb16e47e40438d8a0e2d4e74f75b6aac7efd1c5b3271a158cb8b822eace5f6b437d5d39458c31ae8e6e886e93f2e643f8c9a9 SHA512 2966854d8fd163fd5aaaca5608eeab2a3f0681fe9e22e006840acacd2ff2aaecd6076bcec23989facb7baf64aa96425ad7eeceb4045da44004421b8f10050935
DIST Image-ExifTool-12.33.tar.gz 4958375 BLAKE2B 699529e71e87cf2a5b4d1a69049f48b7b00ce8e720918cb25c2f2b35453fd44c580444bca2ff14d6cef76de99568b2e22b98ea87f45e550d69b40dda464831fe SHA512 7d6bb1942597535cc982e77397b4dc2edee3f361338f82cf2b5f24fd7fa94c148312b125d1d4f37c8dd303eed45173a805eb79ba61a6e74205e21c52f7561d90
+DIST Image-ExifTool-12.42.tar.gz 5042086 BLAKE2B c518906dfc6c354a6bf834044322727ff0c6787f74c387fb24b2320072bb525fd8b0b55d74cc324ac6e2ad6e75de0f3c552db2f6a1e665ab4b1bed9117916c2b SHA512 f7d3dd98623f44473f67ccf740370fd7704b60274efe1272b5219599dba9fe312afe4107937c6d64c5ee11380914b6e97a5248a2abcf88820822f9947cae0f8f
diff --git a/media-libs/exiftool/exiftool-12.42.ebuild b/media-libs/exiftool/exiftool-12.42.ebuild
new file mode 100644
index 000000000000..94747649065c
--- /dev/null
+++ b/media-libs/exiftool/exiftool-12.42.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Check https://exiftool.org/history.html for whether a release is 'production'
+# Ideally don't bump to non-production at all, but certainly don't stable.
+
+DIST_NAME=Image-ExifTool
+inherit perl-module
+
+DESCRIPTION="Read and write meta information in image, audio and video files"
+HOMEPAGE="https://exiftool.org/ http://exiftool.sourceforge.net"
+SRC_URI="https://exiftool.org/${DIST_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~x64-macos"
+IUSE="doc"
+
+src_install() {
+ perl-module_src_install
+ use doc && dodoc -r html/
+
+ insinto /usr/share/${PN}
+ doins -r fmt_files config_files arg_files
+}