summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@aarsen.me>2022-02-03 15:07:11 +0100
committerIonen Wolkens <ionen@gentoo.org>2022-02-05 18:38:01 -0500
commit5f3cc1ee9b0cfcc570d7f6aa0935362e283da0b9 (patch)
tree97a9900433f575bab0b57c8c468584144af40884 /media-libs/fcft
parentgui-apps/foot-terminfo: new package (diff)
downloadgentoo-5f3cc1ee9b0cfcc570d7f6aa0935362e283da0b9.tar.gz
gentoo-5f3cc1ee9b0cfcc570d7f6aa0935362e283da0b9.tar.bz2
gentoo-5f3cc1ee9b0cfcc570d7f6aa0935362e283da0b9.zip
media-libs/fcft: new package
reverse dependency of gui-apps/foot, adopted from guru Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Arsen Arsenović <arsen@aarsen.me> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-libs/fcft')
-rw-r--r--media-libs/fcft/Manifest1
-rw-r--r--media-libs/fcft/fcft-3.0.0.ebuild90
-rw-r--r--media-libs/fcft/metadata.xml18
3 files changed, 109 insertions, 0 deletions
diff --git a/media-libs/fcft/Manifest b/media-libs/fcft/Manifest
new file mode 100644
index 000000000000..698c8a5767e4
--- /dev/null
+++ b/media-libs/fcft/Manifest
@@ -0,0 +1 @@
+DIST fcft-3.0.0.tar.gz 441458 BLAKE2B 9ff83691435953285f1b3f8b51dac7b17453a457eeb910f035e39c6fa3bb39098d3adbb7179f734261a4034e9ea8b034dd03a20ba0c364b7de2efe9b781dfdaa SHA512 fbf7ac7d777bdb530b90b79a0bd8b90d3f7ae8b099c2733304dbe89fbcc1a1a3493d1eac0478bcdee291d8c804da21461737fc3e34164637e86ff737023622b1
diff --git a/media-libs/fcft/fcft-3.0.0.ebuild b/media-libs/fcft/fcft-3.0.0.ebuild
new file mode 100644
index 000000000000..27380210cb01
--- /dev/null
+++ b/media-libs/fcft/fcft-3.0.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit meson python-any-r1
+
+DESCRIPTION="Simple library for font loading and glyph rasterization"
+HOMEPAGE="https://codeberg.org/dnkl/fcft"
+SRC_URI="https://codeberg.org/dnkl/fcft/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples +harfbuzz +libutf8proc test"
+REQUIRED_USE="
+ libutf8proc? ( harfbuzz )
+ examples? ( libutf8proc )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-libs/pixman
+ examples? (
+ dev-libs/libutf8proc:=
+ dev-libs/wayland
+ )
+ harfbuzz? (
+ media-libs/harfbuzz:=
+ )
+ libutf8proc? (
+ dev-libs/libutf8proc:=
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ app-i18n/unicode-data
+ dev-libs/tllist
+ examples? (
+ dev-libs/wayland-protocols
+ )
+ test? (
+ dev-libs/check
+ harfbuzz? ( media-fonts/noto-emoji )
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/scdoc
+ examples? (
+ dev-util/wayland-scanner
+ )
+"
+
+src_prepare() {
+ default
+
+ rm -r unicode || die "Failed removing vendored unicode-data"
+
+ sed -i "s;unicode/UnicodeData.txt;${EPREFIX}/usr/share/unicode-data/UnicodeData.txt;" \
+ meson.build || die "Failed changing UnicodeData.txt to system's copy"
+ sed -i "s;unicode/emoji-data.txt;${EPREFIX}/usr/share/unicode-data/emoji/emoji-data.txt;" \
+ meson.build || die "Failed changing emoji-data.txt to system's copy"
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature harfbuzz grapheme-shaping)
+ $(meson_feature libutf8proc run-shaping)
+ $(meson_use examples)
+ $(use test && meson_use harfbuzz test-text-shaping)
+ -Ddocs=enabled
+ -Dwerror=false
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ local DOCS=( CHANGELOG.md README.md )
+ meson_src_install
+
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+
+ use examples && newbin "${BUILD_DIR}/example/example" fcft-example
+}
diff --git a/media-libs/fcft/metadata.xml b/media-libs/fcft/metadata.xml
new file mode 100644
index 000000000000..f209916337f0
--- /dev/null
+++ b/media-libs/fcft/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>arsen@aarsen.me</email>
+ <name>Arsen Arsenović</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="harfbuzz">Use <pkg>media-libs/harfbuzz</pkg> for grapheme
+ and run shaping</flag>
+ <flag name="libutf8proc">Use <pkg>media-libs/harfbuzz</pkg> and
+ <pkg>dev-libs/libutf8proc</pkg> for run shaping</flag>
+ </use>
+</pkgmetadata>