summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-03-08 11:20:49 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-03-08 11:51:00 +0100
commitffa2e5584838ec6c73b46297f4844efd1626a882 (patch)
treefb2b8f83de6a011156a1d03927fd5dacc5b49e6f /media-libs/fdk-aac/fdk-aac-0.1.6.ebuild
parentdev-ada/asis: Require shared library for both xmlada and gnatcoll (diff)
downloadgentoo-ffa2e5584838ec6c73b46297f4844efd1626a882.tar.gz
gentoo-ffa2e5584838ec6c73b46297f4844efd1626a882.tar.bz2
gentoo-ffa2e5584838ec6c73b46297f4844efd1626a882.zip
media-libs/fdk-aac: Bump to version 0.1.6
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-libs/fdk-aac/fdk-aac-0.1.6.ebuild')
-rw-r--r--media-libs/fdk-aac/fdk-aac-0.1.6.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/fdk-aac/fdk-aac-0.1.6.ebuild b/media-libs/fdk-aac/fdk-aac-0.1.6.ebuild
new file mode 100644
index 000000000000..228a1c8a1bf6
--- /dev/null
+++ b/media-libs/fdk-aac/fdk-aac-0.1.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+ inherit autotools git-r3
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-macos"
+ if [[ ${PV%_p*} != ${PV} ]]; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+ fi
+fi
+
+inherit multilib-minimal
+
+DESCRIPTION="Fraunhofer AAC codec library"
+HOMEPAGE="https://sourceforge.net/projects/opencore-amr/"
+LICENSE="FraunhoferFDK"
+# subslot == N where N is libfdk-aac.so.N
+SLOT="0/1"
+
+IUSE="static-libs examples"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999* ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
+ $(use_enable examples example)
+ )
+ ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use examples; then
+ mv "${ED%/}/usr/bin/"{,fdk-}aac-enc || die
+ fi
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ use examples && einfo "aac-enc was renamed to fdk-aac-enc to prevent file collision with other packages"
+}