summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/fmod/fmod-4.38.00.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/fmod/fmod-4.38.00.ebuild')
-rw-r--r--media-libs/fmod/fmod-4.38.00.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/fmod/fmod-4.38.00.ebuild b/media-libs/fmod/fmod-4.38.00.ebuild
new file mode 100644
index 000000000000..d36dad7272f4
--- /dev/null
+++ b/media-libs/fmod/fmod-4.38.00.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit versionator
+
+MY_P=fmodapi$(delete_all_version_separators)linux
+
+DESCRIPTION="music and sound effects library, and a sound processing system"
+HOMEPAGE="http://www.fmod.org"
+SRC_URI="x86? ( http://www.fmod.org/index.php/release/version/${MY_P}.tar.gz )
+ amd64? ( http://www.fmod.org/index.php/release/version/${MY_P}64.tar.gz )"
+
+LICENSE="BSD BSD-2 fmod"
+SLOT="1"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+RESTRICT="strip test"
+
+QA_FLAGS_IGNORED="opt/fmodex/tools/fsbanklib/.*"
+
+QA_TEXTRELS="opt/fmodex/fmoddesignerapi/api/lib/*
+opt/fmodex/api/lib/*"
+
+src_compile() { :; }
+src_install() {
+ dodir /opt/fmodex
+
+ local fbits=""
+ use amd64 && fbits="64"
+
+ local fsource="${WORKDIR}/${MY_P}${fbits}"
+
+ cd "${fsource}"/api/lib
+
+ cp -f libfmodex${fbits}-${PV}.so libfmodex.so.${PV} || die
+ ln -sf libfmodex.so.${PV} libfmodex.so || die
+ ln -sf libfmodex.so.${PV} libfmodex.so.4 || die
+
+ cp -f libfmodexL${fbits}-${PV}.so libfmodexL.so.${PV} || die
+ ln -sf libfmodexL.so.${PV} libfmodexL.so || die
+ ln -sf libfmodexL.so.${PV} libfmodexL.so.4 || die
+
+ cp -dpR "${fsource}"/* "${D}"/opt/fmodex || die
+
+ dosym /opt/fmodex/api/inc /usr/include/fmodex || die
+
+ use examples || rm -rf "${D}"/opt/fmodex/{,fmoddesignerapi}/examples
+
+ insinto /usr/share/doc/${PF}/pdf
+ doins "${fsource}"/documentation/*.pdf
+ dodoc "${fsource}"/{documentation/*.txt,fmoddesignerapi/*.TXT}
+ rm -rf "${D}"/opt/fmodex/{documentation,fmoddesignerapi/*.TXT}
+
+ echo LDPATH="/opt/fmodex/api/lib" > "${T}"/65fmodex
+ doenvd "${T}"/65fmodex
+}