summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2015-12-09 02:10:49 +0100
committerSebastian Pipping <sping@gentoo.org>2015-12-09 02:10:49 +0100
commitfd4bb68fdb241a27224144045f5ae757f8a76921 (patch)
tree86354448f5028757c7ee205f826db3f54ed87678 /media-libs/gegl
parentmedia-libs/gegl: Fix ffmpeg/libav dependency (bug #567638) (diff)
downloadgentoo-fd4bb68fdb241a27224144045f5ae757f8a76921.tar.gz
gentoo-fd4bb68fdb241a27224144045f5ae757f8a76921.tar.bz2
gentoo-fd4bb68fdb241a27224144045f5ae757f8a76921.zip
media-libs/gegl: Fix USE="-jpeg -png" (bug #567582)
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-libs/gegl')
-rw-r--r--media-libs/gegl/files/gegl-0.3.4-without-jpeg-png.patch58
-rw-r--r--media-libs/gegl/gegl-0.3.4.ebuild1
2 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/gegl/files/gegl-0.3.4-without-jpeg-png.patch b/media-libs/gegl/files/gegl-0.3.4-without-jpeg-png.patch
new file mode 100644
index 000000000000..81f12d149e7b
--- /dev/null
+++ b/media-libs/gegl/files/gegl-0.3.4-without-jpeg-png.patch
@@ -0,0 +1,58 @@
+From 86e5d9c3f51153afde57d8adbe22408cee6321d2 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Wed, 9 Dec 2015 01:48:31 +0100
+Subject: [PATCH] Repair --without-libjpeg and --without-libpng
+
+---
+ configure.ac | 15 ++++++++-------
+ 1 file changed, 8 insertions(+), 7 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 5aa1f3b..95e519b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -809,16 +809,16 @@ if test "x$with_libjpeg" != "xno" && test -z "$LIBJPEG"; then
+ jpeg_ok="no (JPEG header file not found)"
+ fi
+ fi
++
++ if test "$jpeg_ok" != "yes"; then
++ AC_MSG_ERROR([Could not find a usable JPEG library with header files])
++ fi
+ fi
+
+ AM_CONDITIONAL(HAVE_JPEG, test "$jpeg_ok" = "yes")
+
+ AC_SUBST(LIBJPEG)
+
+-if test "$jpeg_ok" != "yes"; then
+- AC_MSG_ERROR([Could not find a usable JPEG library with header files])
+-fi
+-
+
+ ##################
+ # Check for libpng
+@@ -831,6 +831,10 @@ if test "x$with_libpng" != "xno"; then
+ PKG_CHECK_MODULES(PNG, libpng,
+ have_libpng="yes",
+ have_libpng="no (libpng not found)")
++
++ if test "$have_libpng" != "yes"; then
++ AC_MSG_ERROR([Could not find a usable PNG library with header files])
++ fi
+ fi
+
+ AM_CONDITIONAL(HAVE_PNG, test "$have_libpng" = "yes")
+@@ -838,9 +842,6 @@ AM_CONDITIONAL(HAVE_PNG, test "$have_libpng" = "yes")
+ AC_SUBST(PNG_CFLAGS)
+ AC_SUBST(PNG_LIBS)
+
+-if test "$have_libpng" != "yes"; then
+- AC_MSG_ERROR([Could not find a usable PNG library with header files])
+-fi
+
+ ###################
+ # Check for librsvg
+--
+2.6.3
+
diff --git a/media-libs/gegl/gegl-0.3.4.ebuild b/media-libs/gegl/gegl-0.3.4.ebuild
index c2b940950bcb..40fea6e5183a 100644
--- a/media-libs/gegl/gegl-0.3.4.ebuild
+++ b/media-libs/gegl/gegl-0.3.4.ebuild
@@ -81,6 +81,7 @@ pkg_setup() {
src_prepare() {
epatch \
"${FILESDIR}"/${PN}-0.3.4-endian.patch \
+ "${FILESDIR}"/${P}-without-jpeg-png.patch \
"${FILESDIR}"/${P}-underlinking.patch
# FIXME: the following should be proper patch sent to upstream