summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-25 18:43:39 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-25 18:43:39 +0100
commit76ebdaa3d46dc8fcc23375cd365039ef272fd74d (patch)
treee7fdebfdeae45c296527ad7846ee6086d9628c13 /media-libs/giflib/files
parentmedia-libs/opencv: Fix missing PYTHON_DEPS (diff)
downloadgentoo-76ebdaa3d46dc8fcc23375cd365039ef272fd74d.tar.gz
gentoo-76ebdaa3d46dc8fcc23375cd365039ef272fd74d.tar.bz2
gentoo-76ebdaa3d46dc8fcc23375cd365039ef272fd74d.zip
media-libs/giflib: Add patch for GifQuantizeBuffer API
* Patch taken from Archlinux Bug: https://bugs.gentoo.org/682198 Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-libs/giflib/files')
-rw-r--r--media-libs/giflib/files/giflib-5.2.1-fix-missing-quantize-API-symbols.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-libs/giflib/files/giflib-5.2.1-fix-missing-quantize-API-symbols.patch b/media-libs/giflib/files/giflib-5.2.1-fix-missing-quantize-API-symbols.patch
new file mode 100644
index 000000000000..5948f4546858
--- /dev/null
+++ b/media-libs/giflib/files/giflib-5.2.1-fix-missing-quantize-API-symbols.patch
@@ -0,0 +1,32 @@
+From ff8d9a59e79b79657e64430730c35835a84db619 Mon Sep 17 00:00:00 2001
+From: anthraxx <levente@leventepolyak.net>
+Date: Tue, 2 Apr 2019 11:46:18 +0200
+Subject: [PATCH] fix missing quantize API symbols
+
+GifQuantizeBuffer is required by many libs and applications
+like mplayer, libgdiplus (mono) and others.
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index e4ded69..17d0a5c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -29,11 +29,11 @@ LIBPOINT=0
+ LIBVER=$(LIBMAJOR).$(LIBMINOR).$(LIBPOINT)
+
+ SOURCES = dgif_lib.c egif_lib.c gifalloc.c gif_err.c gif_font.c \
+- gif_hash.c openbsd-reallocarray.c
++ gif_hash.c openbsd-reallocarray.c quantize.c
+ HEADERS = gif_hash.h gif_lib.h gif_lib_private.h
+ OBJECTS = $(SOURCES:.c=.o)
+
+-USOURCES = qprintf.c quantize.c getarg.c
++USOURCES = qprintf.c getarg.c
+ UHEADERS = getarg.h
+ UOBJECTS = $(USOURCES:.c=.o)
+
+--
+2.21.0
+