summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Peterson <hazelnusse@gmail.com>2020-01-07 21:08:31 -0800
committerJames Le Cuirot <chewi@gentoo.org>2020-01-08 23:21:23 +0000
commitbb868e6b88a71685c5e38841ef6fce3b4d364299 (patch)
tree0bb020e67b13f91467b58821a1346dcc4f5e9465 /media-libs/glfw/glfw-3.3.1.ebuild
parentsys-power/nut: Rebase patches (diff)
downloadgentoo-bb868e6b88a71685c5e38841ef6fce3b4d364299.tar.gz
gentoo-bb868e6b88a71685c5e38841ef6fce3b4d364299.tar.bz2
gentoo-bb868e6b88a71685c5e38841ef6fce3b4d364299.zip
media-libs/glfw-3.3.1 version bump
As of 2019-04-16, glfw has migrated to Github. This commit updates media-libs/glfw-3.2.1 to use the Github release (which has a different SHA) instead of the Sourceforge release. Signed-off-by: Dale Lukas Peterson <hazelnusse@gmail.com> Closes: https://bugs.gentoo.org/683950 Closes: https://github.com/gentoo/gentoo/pull/14273 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs/glfw/glfw-3.3.1.ebuild')
-rw-r--r--media-libs/glfw/glfw-3.3.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/glfw/glfw-3.3.1.ebuild b/media-libs/glfw/glfw-3.3.1.ebuild
new file mode 100644
index 000000000000..fed5798ce2ab
--- /dev/null
+++ b/media-libs/glfw/glfw-3.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="The Portable OpenGL FrameWork"
+HOMEPAGE="https://www.glfw.org/"
+SRC_URI="https://github.com/glfw/glfw/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~x86"
+IUSE="examples wayland"
+
+RDEPEND="
+ x11-libs/libxkbcommon
+ !wayland? (
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+ )
+ wayland? (
+ dev-libs/wayland
+ media-libs/mesa[egl,wayland]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ wayland? (
+ dev-libs/wayland-protocols
+ kde-frameworks/extra-cmake-modules
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGLFW_BUILD_EXAMPLES="$(usex examples)"
+ -DGLFW_USE_WAYLAND="$(usex wayland)"
+ -DBUILD_SHARED_LIBS=1
+ )
+ cmake-utils_src_configure
+}