summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Audron <audron@cocaine.farm>2020-06-15 15:27:54 +0200
committerStefan Strogin <steils@gentoo.org>2020-06-16 13:35:57 +0300
commit3514eef209b0c22c422ef3ea015f75f188f039ee (patch)
treed2d1fd38f9dfb6c170b0926620442c753823afe2 /media-libs/glfw/glfw-3.3.2.ebuild
parentdev-python/tld: 0.12.2 bump (diff)
downloadgentoo-3514eef209b0c22c422ef3ea015f75f188f039ee.tar.gz
gentoo-3514eef209b0c22c422ef3ea015f75f188f039ee.tar.bz2
gentoo-3514eef209b0c22c422ef3ea015f75f188f039ee.zip
media-libs/glfw: version bump to 3.3.2
Signed-off-by: Max Audron <audron@cocaine.farm> Add x11-libs/libXi to BDEPEND because glfw needs XInput2.h for compilation, but does not link against libXi.so. Closes: https://bugs.gentoo.org/722186 Closes: https://github.com/gentoo/gentoo/pull/16257 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'media-libs/glfw/glfw-3.3.2.ebuild')
-rw-r--r--media-libs/glfw/glfw-3.3.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/glfw/glfw-3.3.2.ebuild b/media-libs/glfw/glfw-3.3.2.ebuild
new file mode 100644
index 000000000000..344e650b9d62
--- /dev/null
+++ b/media-libs/glfw/glfw-3.3.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="The Portable OpenGL FrameWork"
+HOMEPAGE="https://www.glfw.org/"
+SRC_URI="https://github.com/glfw/glfw/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~x86"
+IUSE="wayland"
+
+RDEPEND="
+ x11-libs/libxkbcommon
+ !wayland? (
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+ )
+ wayland? (
+ dev-libs/wayland
+ media-libs/mesa[egl,wayland]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ wayland? ( dev-libs/wayland-protocols )
+"
+BDEPEND="
+ !wayland? ( x11-libs/libXi )
+ wayland? ( kde-frameworks/extra-cmake-modules )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGLFW_BUILD_EXAMPLES=no
+ -DGLFW_USE_WAYLAND="$(usex wayland)"
+ -DBUILD_SHARED_LIBS=1
+ )
+ cmake_src_configure
+}