summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-09-09 14:56:41 +0200
committerTupone Alfredo <tupone@gentoo.org>2019-09-09 14:56:41 +0200
commit59ab0260756b8ca8802f01b44ae6e93e6ac42c2f (patch)
tree8b4c1d1e25710bfb7f3c347e47d6cc6c302f346a /media-libs/glm/glm-0.9.9.6.ebuild
parentdev-tcltk/tcl3d: rm old version, fix unzip dependency (diff)
downloadgentoo-59ab0260756b8ca8802f01b44ae6e93e6ac42c2f.tar.gz
gentoo-59ab0260756b8ca8802f01b44ae6e93e6ac42c2f.tar.bz2
gentoo-59ab0260756b8ca8802f01b44ae6e93e6ac42c2f.zip
media-libs/glm: version bump to 0.9.9.6
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'media-libs/glm/glm-0.9.9.6.ebuild')
-rw-r--r--media-libs/glm/glm-0.9.9.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/glm/glm-0.9.9.6.ebuild b/media-libs/glm/glm-0.9.9.6.ebuild
new file mode 100644
index 000000000000..169bf319fadf
--- /dev/null
+++ b/media-libs/glm/glm-0.9.9.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="OpenGL Mathematics"
+HOMEPAGE="http://glm.g-truc.net/"
+SRC_URI="https://github.com/g-truc/glm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( HappyBunny MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_avx cpu_flags_x86_avx2"
+
+RDEPEND="virtual/opengl"
+
+src_configure() {
+ if use test; then
+ local mycmakeargs=(
+ -DGLM_TEST_ENABLE=ON
+ -DGLM_TEST_ENABLE_SIMD_SSE2="$(usex cpu_flags_x86_sse2 ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_SSE3="$(usex cpu_flags_x86_sse3 ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_AVX="$(usex cpu_flags_x86_avx ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_AVX2="$(usex cpu_flags_x86_avx2 ON OFF)"
+ )
+ fi
+
+ cmake-utils_src_configure
+}