summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/gluon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/gluon')
-rw-r--r--media-libs/gluon/Manifest1
-rw-r--r--media-libs/gluon/files/gluon-0.71.0-gcc-4.7.patch30
-rw-r--r--media-libs/gluon/gluon-0.71.0.ebuild37
-rw-r--r--media-libs/gluon/metadata.xml5
4 files changed, 73 insertions, 0 deletions
diff --git a/media-libs/gluon/Manifest b/media-libs/gluon/Manifest
new file mode 100644
index 000000000000..e42a71a3af8d
--- /dev/null
+++ b/media-libs/gluon/Manifest
@@ -0,0 +1 @@
+DIST gluon-0.71.0.tar.gz 14739398 SHA256 76d1c43eac52563541e0502d50450ddb5c2d1841b882f5f652202ff0ebd21ab3
diff --git a/media-libs/gluon/files/gluon-0.71.0-gcc-4.7.patch b/media-libs/gluon/files/gluon-0.71.0-gcc-4.7.patch
new file mode 100644
index 000000000000..5f54687f3527
--- /dev/null
+++ b/media-libs/gluon/files/gluon-0.71.0-gcc-4.7.patch
@@ -0,0 +1,30 @@
+commit bccbda88a6bc53ac20091bb6aefd2f1b501ba31a
+Author: Christoph Feck <christoph@maxiom.de>
+Date: Fri Mar 23 23:35:09 2012 +0100
+
+ Fix includes
+
+diff --git a/input/linux/detectlinux.cpp b/input/linux/detectlinux.cpp
+index 632249a..6ae85a4 100644
+--- a/input/linux/detectlinux.cpp
++++ b/input/linux/detectlinux.cpp
+@@ -26,6 +26,7 @@
+
+ #include <QtCore/QDir>
+
++#include <unistd.h>
+ // #include <libudev.h>
+
+ using namespace GluonInput;
+diff --git a/input/linux/inputthread.cpp b/input/linux/inputthread.cpp
+index f92b104..202745e 100644
+--- a/input/linux/inputthread.cpp
++++ b/input/linux/inputthread.cpp
+@@ -30,6 +30,7 @@
+ // #include <QtCore/QStringList>
+
+ #include <fcntl.h>
++#include <unistd.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <linux/input.h>
diff --git a/media-libs/gluon/gluon-0.71.0.ebuild b/media-libs/gluon/gluon-0.71.0.ebuild
new file mode 100644
index 000000000000..b0f9b6622dc2
--- /dev/null
+++ b/media-libs/gluon/gluon-0.71.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OPENGL_REQUIRED="always"
+inherit kde4-base versionator
+
+DESCRIPTION="Free and Open Source framework for creating and distributing games"
+HOMEPAGE="http://gluon.tuxfamily.org/"
+SRC_URI="mirror://kde/unstable/${PN}/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64"
+SLOT="4"
+IUSE="debug examples"
+
+DEPEND="
+ media-libs/alure
+ media-libs/libsndfile
+ media-libs/openal
+ virtual/glu
+ virtual/opengl
+ dev-qt/qtdeclarative:4
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-gcc-4.7.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use examples INSTALL_EXAMPLES)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/media-libs/gluon/metadata.xml b/media-libs/gluon/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/media-libs/gluon/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>