summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-10-17 21:23:23 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-10-17 21:24:11 +0200
commit10437271041ed3a588b6d36282efa8f3ed759319 (patch)
treeebdac0422e14982c868c908cb7aec360aab0db6b /media-libs/gmmlib/gmmlib-22.2.1.ebuild
parentdev-libs/libksba: Stabilize 1.6.2 arm64, #877469 (diff)
downloadgentoo-10437271041ed3a588b6d36282efa8f3ed759319.tar.gz
gentoo-10437271041ed3a588b6d36282efa8f3ed759319.tar.bz2
gentoo-10437271041ed3a588b6d36282efa8f3ed759319.zip
media-libs/gmmlib: add 22.2.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-libs/gmmlib/gmmlib-22.2.1.ebuild')
-rw-r--r--media-libs/gmmlib/gmmlib-22.2.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/gmmlib/gmmlib-22.2.1.ebuild b/media-libs/gmmlib/gmmlib-22.2.1.ebuild
new file mode 100644
index 000000000000..d811e64621f4
--- /dev/null
+++ b/media-libs/gmmlib/gmmlib-22.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+
+inherit cmake
+
+DESCRIPTION="Intel Graphics Memory Management Library"
+HOMEPAGE="https://github.com/intel/gmmlib"
+SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
+S="${WORKDIR}/${PN}-intel-${P}"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0/12.2"
+IUSE="+custom-cflags test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
+ "${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
+ "${FILESDIR}"/${PN}-22.1.1_custom_cflags.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ -DBUILD_TYPE="Release"
+ -DOVERRIDE_COMPILER_FLAGS="$(usex !custom-cflags)"
+ )
+
+ cmake_src_configure
+}