summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2021-12-18 11:31:22 +0300
committerConrad Kostecki <conikost@gentoo.org>2021-12-20 10:53:01 +0100
commit6137a05d5d5addaa5d8def50cb0a874a2ac7ac60 (patch)
treefef9c79a3e224517e8f131e4324f959ea629fba9 /media-libs/gmmlib
parentx11-libs/libva-intel-media-driver: depend on gmmlib subslot 0 (diff)
downloadgentoo-6137a05d5d5addaa5d8def50cb0a874a2ac7ac60.tar.gz
gentoo-6137a05d5d5addaa5d8def50cb0a874a2ac7ac60.tar.bz2
gentoo-6137a05d5d5addaa5d8def50cb0a874a2ac7ac60.zip
media-libs/gmmlib: update to 21.3.5 and 22.0.0
Added new subslots as lib has new ABI and new soname. Closes: https://github.com/gentoo/gentoo/pull/23404 Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-libs/gmmlib')
-rw-r--r--media-libs/gmmlib/Manifest2
-rw-r--r--media-libs/gmmlib/gmmlib-21.3.5.ebuild33
-rw-r--r--media-libs/gmmlib/gmmlib-22.0.0.ebuild33
-rw-r--r--media-libs/gmmlib/gmmlib-9999.ebuild2
4 files changed, 69 insertions, 1 deletions
diff --git a/media-libs/gmmlib/Manifest b/media-libs/gmmlib/Manifest
index a493a6a30125..fc0370669398 100644
--- a/media-libs/gmmlib/Manifest
+++ b/media-libs/gmmlib/Manifest
@@ -1 +1,3 @@
DIST intel-gmmlib-21.3.3.tar.gz 747305 BLAKE2B ef055bfdb6efccec5e2e7618677a97b38e314f44486c0d99e704281f2cb78acdf64a1737a8ae2c33b9dde6f60a284b83d9b5ca1949c5a5c7a34894cdbfbb9347 SHA512 9680b2c38f71467a7c4f2c1a6136d1de9c906355ca675ebbafc697daea15fe615aa45f3af3140330f1610946f9c55471038eeb815b1d677b64efb4896515d8fb
+DIST intel-gmmlib-21.3.5.tar.gz 747289 BLAKE2B 288cc0e051389818fcd1025e5f9e650dea6e52df08020aec1c1127afa5e422410c825a45eb78fa8343b583c246501371143a1c8176232b81acf314af3b2513af SHA512 59922ced38983333a29c075cef5d28f02331c0e5a28ac556229e474e9a904a19d952d40daedfcca2365ab35212e0c14bf6db0087283ec5d0b932651c450178c4
+DIST intel-gmmlib-22.0.0.tar.gz 755785 BLAKE2B 30d0e5fa87bbec35532b1934741bdbc1616e1af654d8e90f77b176c757207acf806e9f366d0bcd27b752df19373e0513eca462b39fd1eb6b434c4549b243963e SHA512 7d9a1c216ca5e3d15f53e780698303bb0ab580043a37d83b7b014cc4645e371ec66f49fb0c404fe1856350cc33fb9bf5e7006cb7fd065236086496d7270874aa
diff --git a/media-libs/gmmlib/gmmlib-21.3.5.ebuild b/media-libs/gmmlib/gmmlib-21.3.5.ebuild
new file mode 100644
index 000000000000..2bbab9907b5b
--- /dev/null
+++ b/media-libs/gmmlib/gmmlib-21.3.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Intel Graphics Memory Management Library"
+HOMEPAGE="https://github.com/intel/gmmlib"
+SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
+S="${WORKDIR}/${PN}-intel-${P}"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="+custom-cflags test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
+ "${FILESDIR}"/${PN}-20.4.1_custom_cflags.patch
+ "${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ -DBUILD_TYPE="Release"
+ -DOVERRIDE_COMPILER_FLAGS="$(usex !custom-cflags)"
+ )
+
+ cmake_src_configure
+}
diff --git a/media-libs/gmmlib/gmmlib-22.0.0.ebuild b/media-libs/gmmlib/gmmlib-22.0.0.ebuild
new file mode 100644
index 000000000000..49b1edad54de
--- /dev/null
+++ b/media-libs/gmmlib/gmmlib-22.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Intel Graphics Memory Management Library"
+HOMEPAGE="https://github.com/intel/gmmlib"
+SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
+S="${WORKDIR}/${PN}-intel-${P}"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0/12"
+IUSE="+custom-cflags test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
+ "${FILESDIR}"/${PN}-20.4.1_custom_cflags.patch
+ "${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ -DBUILD_TYPE="Release"
+ -DOVERRIDE_COMPILER_FLAGS="$(usex !custom-cflags)"
+ )
+
+ cmake_src_configure
+}
diff --git a/media-libs/gmmlib/gmmlib-9999.ebuild b/media-libs/gmmlib/gmmlib-9999.ebuild
index 1f972c3b1914..ff83cbf204ae 100644
--- a/media-libs/gmmlib/gmmlib-9999.ebuild
+++ b/media-libs/gmmlib/gmmlib-9999.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="https://github.com/intel/gmmlib"
SRC_URI=""
LICENSE="MIT"
-SLOT="0"
+SLOT="0/12"
IUSE="test +custom-cflags"
RESTRICT="!test? ( test )"