summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/gnonlin/gnonlin-0.10.17.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/gnonlin/gnonlin-0.10.17.ebuild')
-rw-r--r--media-libs/gnonlin/gnonlin-0.10.17.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/gnonlin/gnonlin-0.10.17.ebuild b/media-libs/gnonlin/gnonlin-0.10.17.ebuild
new file mode 100644
index 000000000000..8e22f71f7f3c
--- /dev/null
+++ b/media-libs/gnonlin/gnonlin-0.10.17.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Gnonlin is a set of GStreamer elements to ease the creation of non-linear multimedia editors"
+HOMEPAGE="http://gnonlin.sourceforge.net"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0.10"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+RDEPEND=">=media-libs/gstreamer-0.10.30:0.10
+ >=media-libs/gst-plugins-base-0.10.30:0.10"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( || (
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/gtk-doc-1.3 ) )
+ test? ( dev-libs/check
+ media-libs/gst-plugins-good:0.10 )" # videomixer
+
+src_configure() {
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_enable doc docbook)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README RELEASE
+
+ # For some reason, make install doesn't do this
+ if use doc; then
+ local htmldir="/usr/share/gtk-doc/html"
+ cd "${S}/docs/libs/html"
+ gtkdoc-rebase --html-dir=${htmldir} || die "gtkdoc-rebase failed"
+ insinto "${htmldir}/gnonlin"
+ doins "${S}"/docs/libs/html/* || die "doins docs failed"
+ fi
+}