summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-11-13 12:13:54 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-11-13 12:19:25 +0100
commitbe9b37a3e64de4c6bb9121f99ec1f5ae32fc5442 (patch)
tree950e639c1469a7c190de4419121984340a7bd49f /media-libs/gsound/gsound-1.0.2-r1.ebuild
parentprofiles: keep libinput USE flag masked for sparc stable (diff)
downloadgentoo-be9b37a3e64de4c6bb9121f99ec1f5ae32fc5442.tar.gz
gentoo-be9b37a3e64de4c6bb9121f99ec1f5ae32fc5442.tar.bz2
gentoo-be9b37a3e64de4c6bb9121f99ec1f5ae32fc5442.zip
media-libs/gsound: bump to EAPI=6, properly control vala build
Package-Manager: portage-2.3.2
Diffstat (limited to 'media-libs/gsound/gsound-1.0.2-r1.ebuild')
-rw-r--r--media-libs/gsound/gsound-1.0.2-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/gsound/gsound-1.0.2-r1.ebuild b/media-libs/gsound/gsound-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..fb3ed304f934
--- /dev/null
+++ b/media-libs/gsound/gsound-1.0.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Thin GObject wrapper around the libcanberra sound event library"
+HOMEPAGE="https://wiki.gnome.org/Projects/GSound"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ media-libs/libcanberra
+ introspection? ( >=dev-libs/gobject-introspection-1.2.9:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.20
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure () {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}