summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-07 11:50:35 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-07 11:50:35 +0100
commit2b36d5d24ed6e8e522e44d3666199d051d002738 (patch)
treedc40a75d7084b9c8fbc62f039962e4e6e667544b /media-libs/gsound/gsound-1.0.2.ebuild
parentmedia-gfx/gnome-photos: Drop old (diff)
downloadgentoo-2b36d5d24ed6e8e522e44d3666199d051d002738.tar.gz
gentoo-2b36d5d24ed6e8e522e44d3666199d051d002738.tar.bz2
gentoo-2b36d5d24ed6e8e522e44d3666199d051d002738.zip
media-libs/gsound: Version bump
Package-Manager: portage-2.2.23
Diffstat (limited to 'media-libs/gsound/gsound-1.0.2.ebuild')
-rw-r--r--media-libs/gsound/gsound-1.0.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/gsound/gsound-1.0.2.ebuild b/media-libs/gsound/gsound-1.0.2.ebuild
new file mode 100644
index 000000000000..27738ac02c5d
--- /dev/null
+++ b/media-libs/gsound/gsound-1.0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Thin GObject wrapper around the libcanberra sound event library"
+HOMEPAGE="https://wiki.gnome.org/Projects/GSound"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection"
+
+# vala setup required for vapigen check
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ media-libs/libcanberra
+ introspection? ( >=dev-libs/gobject-introspection-1.2.9:= )
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ >=dev-util/gtk-doc-am-1.20
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure () {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}