summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-06-02 00:57:07 -0500
committerAustin English <wizardedit@gentoo.org>2016-06-02 00:57:44 -0500
commit4231143b2a29252a293bdac1fcfb90d08dd3fb86 (patch)
tree859c5c9da912f5e87671e53933b8c2138e98f8ab /media-libs/gst-plugins-good
parentdev-lang/tcc: fix building with clang (diff)
downloadgentoo-4231143b2a29252a293bdac1fcfb90d08dd3fb86.tar.gz
gentoo-4231143b2a29252a293bdac1fcfb90d08dd3fb86.tar.bz2
gentoo-4231143b2a29252a293bdac1fcfb90d08dd3fb86.zip
media-libs/gst-plugins-good: fix building gst-plugins-good-0.10.31 with clang
Gentoo-Bug: https://bugs.gentoo.org/558080 Package-Manager: portage-2.2.26
Diffstat (limited to 'media-libs/gst-plugins-good')
-rw-r--r--media-libs/gst-plugins-good/files/gst-plugins-good-0.10-clang.patch18
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-0.10.31-r2.ebuild61
2 files changed, 79 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-good/files/gst-plugins-good-0.10-clang.patch b/media-libs/gst-plugins-good/files/gst-plugins-good-0.10-clang.patch
new file mode 100644
index 000000000000..3016bfb23d3d
--- /dev/null
+++ b/media-libs/gst-plugins-good/files/gst-plugins-good-0.10-clang.patch
@@ -0,0 +1,18 @@
+--- gst/goom/mmx.h.orig 2011-12-11 19:48:11.000000000 +0100
++++ gst/goom/mmx.h 2013-02-08 00:54:14.000000000 +0100
+@@ -715,13 +715,13 @@ void zoom_filter_xmmx (int prevX, int pr
+ { \
+ printf("emms()\n"); \
+ __asm__ __volatile__ ("emms" \
+- "st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)"); \
++ "st", "st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)"); \
+ }
+
+ #else
+
+ #define emms() __asm__ __volatile__ ("emms"::: \
+- "st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)")
++ "st", "st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)")
+
+ #endif
+
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-0.10.31-r2.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-0.10.31-r2.ebuild
new file mode 100644
index 000000000000..7cc422164975
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-0.10.31-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GST_ORG_MODULE="gst-plugins-good"
+inherit eutils flag-o-matic gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-0.10.36:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-0.10.36:${SLOT}[${MULTILIB_USEDEP}]
+ >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ !<media-libs/gst-plugins-bad-0.10.22:${SLOT}
+"
+# audioparsers and qtmux moves
+
+src_configure() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ multilib-minimal_src_configure
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.10-clang.patch"
+}
+
+multilib_src_configure() {
+ # Always enable optional bz2 support for matroska
+ # Always enable optional zlib support for qtdemux and matroska
+ # Many media files require these to work, as some container headers are often
+ # compressed, bug #291154
+ gstreamer_multilib_src_configure \
+ --enable-bz2 \
+ --enable-zlib \
+ --disable-examples \
+ --with-default-audiosink=autoaudiosink \
+ --with-default-visualizer=goom
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}