summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <listout@protonmail.com>2022-11-02 11:16:36 +0530
committerMart Raudsepp <leio@gentoo.org>2022-11-20 18:12:28 +0000
commit99857f45011b1da80a5fc0ec73050dec67c65d35 (patch)
treeb65eb27a4f21bd0d77606696f383ff49c467bd9b /media-libs/gst-plugins-good
parentpackage.mask: Stop last rite of media-libs/libvisual for now (diff)
downloadgentoo-99857f45011b1da80a5fc0ec73050dec67c65d35.tar.gz
gentoo-99857f45011b1da80a5fc0ec73050dec67c65d35.tar.bz2
gentoo-99857f45011b1da80a5fc0ec73050dec67c65d35.zip
media-libs/gstreamer: Version bump to 1.20.4
Closes: https://bugs.gentoo.org/877325 Signed-off-by: brahmajit das <listout@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/28086 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-libs/gst-plugins-good')
-rw-r--r--media-libs/gst-plugins-good/Manifest1
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-1.20.4.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-good/Manifest b/media-libs/gst-plugins-good/Manifest
index 8035d1759b43..362dc6c30cdd 100644
--- a/media-libs/gst-plugins-good/Manifest
+++ b/media-libs/gst-plugins-good/Manifest
@@ -1,2 +1,3 @@
DIST gst-plugins-good-1.20.2.tar.xz 3411008 BLAKE2B 45eb497d240bf9b05cfbf85babe5ef85fb8a7f25f1b470f131f319064e1dc04f334d4b7dede4f0aedd73dca01605b7e00e2ddc587bcf9ccce6989a9e99776cb1 SHA512 a10ea48fdfbe741e9bc63036b011748558f89968aaa525380ac99884c27463d190c0b49e2d98b4f554eee6ead8a5c5da3ba62e5b0b1fe54877598beccc68a933
DIST gst-plugins-good-1.20.3.tar.xz 3417252 BLAKE2B 5f288541598d2c308fbb1d5e36e54e8dd4c6e9d7dd71f41b778fbdfe883ed48e8d13fa53d05518cc671de029d804f7dc1d93396de9d199d45ec131230926d33c SHA512 98bb2dd428edaa1a5846fb47b1f42a1e99541faf05cdb0fb632d4a1a1e4fb2c1f9d1229bf0aa2ddcbce139533e9fd51f8f9a1175cd8a8729c5179750ca84afa1
+DIST gst-plugins-good-1.20.4.tar.xz 3424532 BLAKE2B 2b9fa0227c13c6a81a91b4d337c3d52d6e8bd63d04710ee6bc45ec7b70de3f35c57148786356e08a253b1bbc9473411d9b0f1346433396e2403680690823c06f SHA512 d1a1d3a161fc33ecfae2b1336391571210511926a5017ea512a0bef7ab3577fb98326a96b6c5a2ffb48c8e2c7c3bf8e957e489edd0cf44e8ed8518656768c7ce
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.20.4.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.20.4.ebuild
new file mode 100644
index 000000000000..350fe1793a50
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-1.20.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE="gst-plugins-good"
+
+inherit gstreamer-meson
+
+DESCRIPTION="Basepack of plugins for GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+orc"
+
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+DOCS=( AUTHORS ChangeLog NEWS README.md RELEASE )
+
+# Fixes backported to 1.20.1, to be removed in 1.20.2+
+PATCHES=(
+)
+
+multilib_src_configure() {
+ GST_PLUGINS_NOAUTO="bz2"
+
+ local emesonargs=(
+ -Dbz2=enabled
+
+ # gst-plugins-ximagesrc
+ -Dximagesrc=disabled
+ -Dximagesrc-xshm=disabled
+ -Dximagesrc-xfixes=disabled
+ -Dximagesrc-xdamage=disabled
+
+ # gst-plugins-v4l2
+ -Dv4l2=disabled
+ )
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}