summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-05-11 18:02:10 +0200
committerMichael Palimaka <kensington@gentoo.org>2019-05-15 22:07:07 +1000
commit9f6df59f497fe651033ae2f3625215fc38c4548d (patch)
tree09d2e7043513f61e81e2d66753c81c37cc058062 /media-libs/guilib/guilib-1.2.1-r1.ebuild
parentmedia-libs/guilib: use HTTPS (diff)
downloadgentoo-9f6df59f497fe651033ae2f3625215fc38c4548d.tar.gz
gentoo-9f6df59f497fe651033ae2f3625215fc38c4548d.tar.bz2
gentoo-9f6df59f497fe651033ae2f3625215fc38c4548d.zip
media-libs/guilib: use HTTPS, EAPI=7 bump
Closes: https://bugs.gentoo.org/685636 Closes: https://github.com/gentoo/gentoo/pull/11971 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'media-libs/guilib/guilib-1.2.1-r1.ebuild')
-rw-r--r--media-libs/guilib/guilib-1.2.1-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/guilib/guilib-1.2.1-r1.ebuild b/media-libs/guilib/guilib-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..381f5353ebae
--- /dev/null
+++ b/media-libs/guilib/guilib-1.2.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P=GUIlib-${PV}
+
+DESCRIPTION="Simple widget set for SDL"
+HOMEPAGE="https://www.libsdl.org/projects/GUIlib/"
+SRC_URI="https://www.libsdl.org/projects/GUIlib/src/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/libsdl-1.0.1"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ sed -i -e '/^noinst_PROGRAMS/,$d' Makefile.am || die
+
+ rm -f *.m4
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if use static-libs; then
+ find "${ED}" -name '*.la' -exec rm {} + || die
+ fi
+}