summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2021-12-03 18:58:27 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2021-12-03 18:58:27 +0100
commit231e21ff2ea467553ece8eee7f37f0d43ed89ada (patch)
tree6102dfe842b07a7f735a4bdb03be3e03ecc07a8c /media-libs/hamlib
parentx11-misc/grub2-theme-preview: 2.4.2 (diff)
downloadgentoo-231e21ff2ea467553ece8eee7f37f0d43ed89ada.tar.gz
gentoo-231e21ff2ea467553ece8eee7f37f0d43ed89ada.tar.bz2
gentoo-231e21ff2ea467553ece8eee7f37f0d43ed89ada.zip
media-libs/hamlib: Version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-libs/hamlib')
-rw-r--r--media-libs/hamlib/Manifest1
-rw-r--r--media-libs/hamlib/hamlib-4.4.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/media-libs/hamlib/Manifest b/media-libs/hamlib/Manifest
index 625133f7cba8..985a81dd4f2c 100644
--- a/media-libs/hamlib/Manifest
+++ b/media-libs/hamlib/Manifest
@@ -1,2 +1,3 @@
DIST hamlib-4.2.tar.gz 2311775 BLAKE2B 4fe8d3e6d489369aede1a4cd59f01be44a7787ca71c21c5b92d436666c67de68013f488834d0f57238e6a947c24cd5b4c6c667397dec30392f1cccd695df252e SHA512 08ccf4e592fbae938ae1aaa5afede7e2e6ec7d23b449a65b00e093502f4aeb36930624f055d9802349f77df9dd2b7b983aa44d83f8c62a6de5789e7df627f804
DIST hamlib-4.3.1.tar.gz 2356944 BLAKE2B c803d253c867303cbde98b6f2e10f610aac111b7bd81fd343e1396cb86384b1c26942e5ccb8e395e073f9aa3d48e6f9edc1b64da14b2ec5ca09f98fbd3dee667 SHA512 8dee4676a19de7ac1ef733a4285b76e918f11aad6594d0557d36df295faf04c615e0993edb2f9ed5e7aea718c184603fec831caf28b75026c705f0b2e4b9eca7
+DIST hamlib-4.4.tar.gz 2401399 BLAKE2B 4256b5b4374c62ef4fb957d29deda95aa9d15a8b52b81c5db1c07f3ebbf4c8e48c6c082769cef82c8457b3f813ac00ef7a37136615747f2c93e5275a112891e7 SHA512 37366ba180031de34da447c3d4e0086f156b893f57b5ab9bbc38b8e1f4bf9310fa1a9eb2a6d7884f1f11900dbdb811b4071e023aba571ea0ac5d07ddb122bf7b
diff --git a/media-libs/hamlib/hamlib-4.4.ebuild b/media-libs/hamlib/hamlib-4.4.ebuild
new file mode 100644
index 000000000000..f7d9f12e8a35
--- /dev/null
+++ b/media-libs/hamlib/hamlib-4.4.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..10} )
+MY_P=${P/_rc2/~rc2}
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Ham radio backend rig control libraries"
+HOMEPAGE="http://www.hamlib.org"
+SRC_URI="mirror://sourceforge/hamlib/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0/4.2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc perl python tcl"
+
+RESTRICT="test"
+
+RDEPEND="
+ =virtual/libusb-0*
+ dev-libs/libxml2
+ sys-libs/readline:0=
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ tcl? ( dev-lang/tcl:0= )"
+
+DEPEND=" ${RDEPEND}
+ virtual/pkgconfig
+ dev-lang/swig
+ >=sys-devel/libtool-2.2
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=(AUTHORS NEWS PLAN README README.betatester README.developer)
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # fix hardcoded libdir paths
+ sed -i -e "s#fix}/lib#fix}/$(get_libdir)/hamlib#" \
+ -e "s#fix}/include#fix}/include/hamlib#" \
+ hamlib.pc.in || die "sed failed"
+
+ # Correct install target to whatever INSTALLDIRS says and use vendor
+ # installdirs everywhere (bug #611550)
+ sed -i -e "s#install_site#install#" \
+ -e 's#MAKEFILE="Hamlib-pl.mk"#MAKEFILE="Hamlib-pl.mk" INSTALLDIRS=vendor#' \
+ bindings/Makefile.am || die "sed failed patching for perl"
+
+ # make building of documentation compatible with autotools-utils
+ sed -i -e "s/doc:/html:/g" doc/Makefile.am || die "sed failed"
+
+ eautoreconf
+
+ eapply_user
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir)/hamlib \
+ --disable-static \
+ --with-xml-support \
+ $(use_with perl perl-binding) \
+ $(use_with python python-binding) \
+ $(use_with tcl tcl-binding)
+}
+
+src_compile() {
+ emake
+ use doc && emake html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ use python && python_optimize
+
+ use doc && HTML_DOCS=( doc/html/ )
+ einstalldocs
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins hamlib.pc
+
+ echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
+ doenvd "${T}"/73hamlib
+}