summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2023-04-16 17:20:42 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2023-04-16 17:22:56 +0200
commit692f7bec3a069420ac6d7ab9fb16718e1a77fdbb (patch)
tree66f4046bc537fca6722d65f77fe9fbf91bcd3b8c /media-libs/hamlib
parentx11-misc/xsel: keyword 1.2.0-r2 for ~loong (diff)
downloadgentoo-692f7bec3a069420ac6d7ab9fb16718e1a77fdbb.tar.gz
gentoo-692f7bec3a069420ac6d7ab9fb16718e1a77fdbb.tar.bz2
gentoo-692f7bec3a069420ac6d7ab9fb16718e1a77fdbb.zip
media-libs/hamlib: add 4.5.5
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-libs/hamlib')
-rw-r--r--media-libs/hamlib/Manifest1
-rw-r--r--media-libs/hamlib/hamlib-4.5.5.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/media-libs/hamlib/Manifest b/media-libs/hamlib/Manifest
index 425f7bb3083e..7f94e4c0029e 100644
--- a/media-libs/hamlib/Manifest
+++ b/media-libs/hamlib/Manifest
@@ -1 +1,2 @@
DIST hamlib-4.5.4.tar.gz 2598483 BLAKE2B 7f9654d6aa8c241e58dfdcd4d1967cb0d2415f9cd7a06de68f0ec0e837442db4fd373cfcd08406afca6d6c6c71435358bc5d31969fb0569dea5853b4f3d4f38e SHA512 882fb517a3e5854cdaad506520e96c7736214fe27d1ac053f0510e3c5c08e1bf40217442f519d1c4be92e3d05135c7bd90bc0d60f334f52994e69b2ce9d3f442
+DIST hamlib-4.5.5.tar.gz 2603846 BLAKE2B ad4a286a7aa1e972707cb9ed15a4268909a7d252a64b98b01d35c9d9e42c605cd600e819e195e49d501c1e135191fda585581e27801fa217c9141236a81ad770 SHA512 2cdff2630e89fa95c7ac40e998492e8a04e000fcca18b9491ddcb967927ffaa771ed2e6ac3232a060947883533a6ae7405042a2f8fdb1de157d71f74381f5899
diff --git a/media-libs/hamlib/hamlib-4.5.5.ebuild b/media-libs/hamlib/hamlib-4.5.5.ebuild
new file mode 100644
index 000000000000..cc3babe21d69
--- /dev/null
+++ b/media-libs/hamlib/hamlib-4.5.5.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+MY_P=${P/_rc2/~rc2}
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Ham radio backend rig control libraries"
+HOMEPAGE="http://www.hamlib.org"
+SRC_URI="mirror://sourceforge/hamlib/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0/4.2"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="doc perl python tcl"
+
+RESTRICT="test"
+
+RDEPEND="
+ =virtual/libusb-0*
+ dev-libs/libxml2
+ sys-libs/readline:0=
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ tcl? ( dev-lang/tcl:0= )"
+
+DEPEND=" ${RDEPEND}
+ virtual/pkgconfig
+ dev-lang/swig
+ >=sys-devel/libtool-2.2
+ doc? ( app-doc/doxygen
+ dev-util/source-highlight )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=(AUTHORS NEWS PLAN README README.betatester README.developer)
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # fix hardcoded libdir paths
+ sed -i -e "s#fix}/lib#fix}/$(get_libdir)/hamlib#" \
+ -e "s#fix}/include#fix}/include/hamlib#" \
+ hamlib.pc.in || die "sed failed"
+
+ # Correct install target to whatever INSTALLDIRS says and use vendor
+ # installdirs everywhere (bug #611550)
+ sed -i -e "s#install_site#install#" \
+ -e 's#MAKEFILE="Hamlib-pl.mk"#MAKEFILE="Hamlib-pl.mk" INSTALLDIRS=vendor#' \
+ bindings/Makefile.am || die "sed failed patching for perl"
+
+ # make building of documentation compatible with autotools-utils
+ sed -i -e "s/doc:/html:/g" doc/Makefile.am || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir)/hamlib \
+ --disable-static \
+ --with-xml-support \
+ $(use_with perl perl-binding) \
+ $(use_with python python-binding) \
+ $(use_with tcl tcl-binding)
+}
+
+src_compile() {
+ emake
+ use doc && emake html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ use python && python_optimize
+
+ use doc && HTML_DOCS=( doc/html/ )
+ einstalldocs
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins hamlib.pc
+
+ echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
+ doenvd "${T}"/73hamlib
+
+ find "${ED}" -name '*.la' -delete || die
+}