summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2023-01-13 19:10:06 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2023-01-13 19:10:33 +0100
commit90febe47b16a6eefa24b56412305ed5164db1b65 (patch)
treeca6b229fc76c64c620850887cf44276b201b4a4d /media-libs/hamlib
parentnet-vpn/vpnc: sync live ebuild (diff)
downloadgentoo-90febe47b16a6eefa24b56412305ed5164db1b65.tar.gz
gentoo-90febe47b16a6eefa24b56412305ed5164db1b65.tar.bz2
gentoo-90febe47b16a6eefa24b56412305ed5164db1b65.zip
media-libs/hamlib: add 4.5.4
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-libs/hamlib')
-rw-r--r--media-libs/hamlib/Manifest1
-rw-r--r--media-libs/hamlib/hamlib-4.5.4.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/media-libs/hamlib/Manifest b/media-libs/hamlib/Manifest
index bce411fa3727..25ce0be5f8d6 100644
--- a/media-libs/hamlib/Manifest
+++ b/media-libs/hamlib/Manifest
@@ -1,2 +1,3 @@
DIST hamlib-4.4.tar.gz 2401399 BLAKE2B 4256b5b4374c62ef4fb957d29deda95aa9d15a8b52b81c5db1c07f3ebbf4c8e48c6c082769cef82c8457b3f813ac00ef7a37136615747f2c93e5275a112891e7 SHA512 37366ba180031de34da447c3d4e0086f156b893f57b5ab9bbc38b8e1f4bf9310fa1a9eb2a6d7884f1f11900dbdb811b4071e023aba571ea0ac5d07ddb122bf7b
DIST hamlib-4.5.3.tar.gz 2590200 BLAKE2B 7c06a20a1185a2e413fee56231f3e0f6aa77a7585b9853896b00abb773e2e23fc5e97a8a3fbb873528282756ee674b1ca5b2b14f0fe8e6b9b8e8f7e8ffa223f2 SHA512 be3b58c7276c1289d85b4dc9054016757200fde06d66116f7a1687442e53bf322f0a3ae974c9b784cbd0bff0c64b901b97fac74184f4b4a0fdf1f5079d0ea509
+DIST hamlib-4.5.4.tar.gz 2598483 BLAKE2B 7f9654d6aa8c241e58dfdcd4d1967cb0d2415f9cd7a06de68f0ec0e837442db4fd373cfcd08406afca6d6c6c71435358bc5d31969fb0569dea5853b4f3d4f38e SHA512 882fb517a3e5854cdaad506520e96c7736214fe27d1ac053f0510e3c5c08e1bf40217442f519d1c4be92e3d05135c7bd90bc0d60f334f52994e69b2ce9d3f442
diff --git a/media-libs/hamlib/hamlib-4.5.4.ebuild b/media-libs/hamlib/hamlib-4.5.4.ebuild
new file mode 100644
index 000000000000..c09e460664c0
--- /dev/null
+++ b/media-libs/hamlib/hamlib-4.5.4.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+MY_P=${P/_rc2/~rc2}
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Ham radio backend rig control libraries"
+HOMEPAGE="http://www.hamlib.org"
+SRC_URI="mirror://sourceforge/hamlib/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0/4.2"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="doc perl python tcl"
+
+RESTRICT="test"
+
+RDEPEND="
+ =virtual/libusb-0*
+ dev-libs/libxml2
+ sys-libs/readline:0=
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ tcl? ( dev-lang/tcl:0= )"
+
+DEPEND=" ${RDEPEND}
+ virtual/pkgconfig
+ dev-lang/swig
+ >=sys-devel/libtool-2.2
+ doc? ( app-doc/doxygen
+ dev-util/source-highlight )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=(AUTHORS NEWS PLAN README README.betatester README.developer)
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # fix hardcoded libdir paths
+ sed -i -e "s#fix}/lib#fix}/$(get_libdir)/hamlib#" \
+ -e "s#fix}/include#fix}/include/hamlib#" \
+ hamlib.pc.in || die "sed failed"
+
+ # Correct install target to whatever INSTALLDIRS says and use vendor
+ # installdirs everywhere (bug #611550)
+ sed -i -e "s#install_site#install#" \
+ -e 's#MAKEFILE="Hamlib-pl.mk"#MAKEFILE="Hamlib-pl.mk" INSTALLDIRS=vendor#' \
+ bindings/Makefile.am || die "sed failed patching for perl"
+
+ # make building of documentation compatible with autotools-utils
+ sed -i -e "s/doc:/html:/g" doc/Makefile.am || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir)/hamlib \
+ --disable-static \
+ --with-xml-support \
+ $(use_with perl perl-binding) \
+ $(use_with python python-binding) \
+ $(use_with tcl tcl-binding)
+}
+
+src_compile() {
+ emake
+ use doc && emake html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ use python && python_optimize
+
+ use doc && HTML_DOCS=( doc/html/ )
+ einstalldocs
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins hamlib.pc
+
+ echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
+ doenvd "${T}"/73hamlib
+
+ find "${ED}" -name '*.la' -delete || die
+}