summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-08-18 17:02:35 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-18 17:02:49 +0200
commit3b68e1adaa846f544156dc17db2e520b5f10f8e9 (patch)
tree36ae3ce1a24320eac86bc0de8b707d89d5bf7ba4 /media-libs/harfbuzz/harfbuzz-9999.ebuild
parentmedia-libs/mutagen: remove old (diff)
downloadgentoo-3b68e1adaa846f544156dc17db2e520b5f10f8e9.tar.gz
gentoo-3b68e1adaa846f544156dc17db2e520b5f10f8e9.tar.bz2
gentoo-3b68e1adaa846f544156dc17db2e520b5f10f8e9.zip
media-libs/harfbuzz: Sync (and improve) live ebuild.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'media-libs/harfbuzz/harfbuzz-9999.ebuild')
-rw-r--r--media-libs/harfbuzz/harfbuzz-9999.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/media-libs/harfbuzz/harfbuzz-9999.ebuild b/media-libs/harfbuzz/harfbuzz-9999.ebuild
index fbd9ff51526f..c785260b6c40 100644
--- a/media-libs/harfbuzz/harfbuzz-9999.ebuild
+++ b/media-libs/harfbuzz/harfbuzz-9999.ebuild
@@ -3,21 +3,24 @@
EAPI=6
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/harfbuzz.git"
-[[ ${PV} == 9999 ]] && inherit git-r3 autotools
-
PYTHON_COMPAT=( python2_7 )
inherit eutils flag-o-matic libtool multilib-minimal python-any-r1 xdg-utils
DESCRIPTION="An OpenType text shaping engine"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
-[[ ${PV} == 9999 ]] || SRC_URI="https://www.freedesktop.org/software/harfbuzz/release/${P}.tar.bz2"
+
+if [[ ${PV} != 9999 ]] ; then
+ SRC_URI="https://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+else
+ inherit git-r3 autotools
+ #EGIT_REPO_URI="git://anongit.freedesktop.org/harfbuzz"
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/harfbuzz.git"
+fi
LICENSE="Old-MIT ISC icu"
SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
IUSE="+cairo debug fontconfig +glib +graphite icu +introspection static-libs test +truetype"
REQUIRED_USE="introspection? ( glib )"
@@ -25,7 +28,7 @@ REQUIRED_USE="introspection? ( glib )"
RDEPEND="
cairo? ( x11-libs/cairo:= )
fontconfig? ( media-libs/fontconfig:1.0[${MULTILIB_USEDEP}] )
- glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
+ glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
introspection? ( >=dev-libs/gobject-introspection-1.34:= )
@@ -38,7 +41,7 @@ DEPEND="${RDEPEND}
"
# eautoreconf requires gobject-introspection-common
# ragel needed if regenerating *.hh files from *.rl
-[[ ${PV} = 9999 ]] && DEPEND="${DEPEND}
+[[ ${PV} = 9999 ]] && DEPEND+="
>=dev-libs/gobject-introspection-common-1.34
dev-util/ragel
"
@@ -46,7 +49,6 @@ DEPEND="${RDEPEND}
pkg_setup() {
use test && python-any-r1_pkg_setup
if ! use debug ; then
- append-cppflags -DNDEBUG
append-cppflags -DHB_NDEBUG
fi
}