summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-03 13:05:36 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-03 13:06:29 +0200
commit2a59cd049fe2ba0787bc77a63df0490bf91b406d (patch)
treeafc87bc5806114262269ff6de307af11e195fe3f /media-libs/harfbuzz
parentelisp.eclass: Support EAPI 7. (diff)
downloadgentoo-2a59cd049fe2ba0787bc77a63df0490bf91b406d.tar.gz
gentoo-2a59cd049fe2ba0787bc77a63df0490bf91b406d.tar.bz2
gentoo-2a59cd049fe2ba0787bc77a63df0490bf91b406d.zip
media-libs/harfbuzz: Fixed test failure.
Closes: https://bugs.gentoo.org/654194 Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'media-libs/harfbuzz')
-rw-r--r--media-libs/harfbuzz/files/harfbuzz-1.7.6-test_fixup.patch22
-rw-r--r--media-libs/harfbuzz/harfbuzz-1.7.6.ebuild4
2 files changed, 26 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/files/harfbuzz-1.7.6-test_fixup.patch b/media-libs/harfbuzz/files/harfbuzz-1.7.6-test_fixup.patch
new file mode 100644
index 000000000000..a9187561849d
--- /dev/null
+++ b/media-libs/harfbuzz/files/harfbuzz-1.7.6-test_fixup.patch
@@ -0,0 +1,22 @@
+From 93b03119da8674a3eddb7879857e9f17fa16fd2a Mon Sep 17 00:00:00 2001
+From: violet-sippial <38817272+violet-sippial@users.noreply.github.com>
+Date: Sat, 28 Apr 2018 20:29:13 +0200
+Subject: [PATCH] [subset] Do not compare ttx progress output in the tests
+
+Suppress progress messages of ttx. This avoids comparing this output to the reference file which lets the test fail.
+---
+ test/subset/run-tests.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/test/subset/run-tests.py b/test/subset/run-tests.py
+index 0b119fee6..1cd1a19f6 100755
+--- a/test/subset/run-tests.py
++++ b/test/subset/run-tests.py
+@@ -80,6 +80,7 @@ def run_test(test, should_check_ots):
+ def run_ttx(file):
+ print ("ttx %s" % file)
+ cli_args = ["ttx",
++ "-q",
+ "-o-",
+ file]
+ return cmd(cli_args)
diff --git a/media-libs/harfbuzz/harfbuzz-1.7.6.ebuild b/media-libs/harfbuzz/harfbuzz-1.7.6.ebuild
index 652f9591f8d5..47bad82a2549 100644
--- a/media-libs/harfbuzz/harfbuzz-1.7.6.ebuild
+++ b/media-libs/harfbuzz/harfbuzz-1.7.6.ebuild
@@ -47,6 +47,10 @@ if [[ ${PV} = 9999 ]] ; then
"
fi
+PATCHES=(
+ "${FILESDIR}/${P}-test_fixup.patch"
+)
+
pkg_setup() {
use test && python-any-r1_pkg_setup
if ! use debug ; then