summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2018-09-30 21:41:34 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-11 20:42:49 +0200
commit4f7fbc18a745b1d120e866c2ea7d601fbe7e4a6e (patch)
treebf4a9d823c526346cafad2cdb9746d153c1b6537 /media-libs/ilmbase/ilmbase-2.3.0.ebuild
parentnet-misc/smb4k: Drop 2.1.0 (diff)
downloadgentoo-4f7fbc18a745b1d120e866c2ea7d601fbe7e4a6e.tar.gz
gentoo-4f7fbc18a745b1d120e866c2ea7d601fbe7e4a6e.tar.bz2
gentoo-4f7fbc18a745b1d120e866c2ea7d601fbe7e4a6e.zip
media-libs/ilmbase: bump to version 2.3.0
Remove .la files, as the package provides pkgconfig files. Closes: https://bugs.gentoo.org/639998 Suggested-by: Jonathan Scruggs <dracwyrm@gentoo.org> Signed-off-by: Bernd Waibel <waebbl@gmail.com> Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-libs/ilmbase/ilmbase-2.3.0.ebuild')
-rw-r--r--media-libs/ilmbase/ilmbase-2.3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/ilmbase/ilmbase-2.3.0.ebuild b/media-libs/ilmbase/ilmbase-2.3.0.ebuild
new file mode 100644
index 000000000000..318a31fd3910
--- /dev/null
+++ b/media-libs/ilmbase/ilmbase-2.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit multilib-minimal
+
+DESCRIPTION="OpenEXR ILM Base libraries"
+HOMEPAGE="http://openexr.com/"
+SRC_URI="https://github.com/openexr/openexr/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/24" # based on SONAME
+KEYWORDS="~amd64 -arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="static-libs"
+
+DEPEND="virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md )
+MULTILIB_WRAPPED_HEADERS=( /usr/include/OpenEXR/IlmBaseConfig.h )
+
+multilib_src_configure() {
+ # Disable use of ucontext.h wrt #482890
+ if use hppa || use ppc || use ppc64; then
+ export ac_cv_header_ucontext_h=no
+ fi
+
+ ECONF_SOURCE=${S} econf "$(use_enable static-libs static)"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # package provides pkg-config files
+ find "${D}" -name '*.la' -delete || die
+}