summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-10-29 11:44:24 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-29 11:44:58 +0200
commitc110a9f43b68805d7ddb6774bf50edb0b0ace369 (patch)
tree59455bccb43b3352267099443b67b73db7693c26 /media-libs/jasper
parentkde-misc/ktoshiba: Remove 5.3 (diff)
downloadgentoo-c110a9f43b68805d7ddb6774bf50edb0b0ace369.tar.gz
gentoo-c110a9f43b68805d7ddb6774bf50edb0b0ace369.tar.bz2
gentoo-c110a9f43b68805d7ddb6774bf50edb0b0ace369.zip
media-libs/jasper: Require C11 support
Gentoo-bug: 598418 Package-Manager: portage-2.3.2
Diffstat (limited to 'media-libs/jasper')
-rw-r--r--media-libs/jasper/jasper-1.900.15.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/media-libs/jasper/jasper-1.900.15.ebuild b/media-libs/jasper/jasper-1.900.15.ebuild
index 7c007cdc115f..5f00d8fb4a16 100644
--- a/media-libs/jasper/jasper-1.900.15.ebuild
+++ b/media-libs/jasper/jasper-1.900.15.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-inherit autotools multilib-minimal
+inherit autotools flag-o-matic multilib-minimal
DESCRIPTION="Implementation of the codec specified in the JPEG-2000 Part-1 standard"
HOMEPAGE="http://www.ece.uvic.ca/~mdadams/jasper/"
@@ -42,6 +42,13 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # bug 598418
+ append-cflags -std=gnu11
+
+ multilib-minimal_src_configure
+}
+
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
$(use_enable jpeg libjpeg) \