summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/jbigkit/jbigkit-2.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/jbigkit/jbigkit-2.1.ebuild')
-rw-r--r--media-libs/jbigkit/jbigkit-2.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-libs/jbigkit/jbigkit-2.1.ebuild b/media-libs/jbigkit/jbigkit-2.1.ebuild
new file mode 100644
index 000000000000..db72bc36c398
--- /dev/null
+++ b/media-libs/jbigkit/jbigkit-2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs multilib-minimal
+
+DESCRIPTION="data compression algorithm for bi-level high-resolution images"
+HOMEPAGE="http://www.cl.cam.ac.uk/~mgk25/jbigkit/"
+SRC_URI="http://www.cl.cam.ac.uk/~mgk25/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/2.1" # Since we install libjbig.so and libjbig85.so without version, use ${PV} like 2.1
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+DOCS="ANNOUNCE CHANGES TODO libjbig/*.txt pbmtools/*.txt"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ multilib_copy_sources
+ tc-export AR CC RANLIB
+}
+
+multilib_src_compile() {
+ emake \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ $(multilib_is_native_abi || echo lib)
+
+ if use static-libs; then
+ cd libjbig && emake static
+ fi
+}
+
+multilib_src_test() {
+ LD_LIBRARY_PATH=${BUILD_DIR}/libjbig emake -j1 test
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ dobin pbmtools/jbgtopbm{,85} pbmtools/pbmtojbg{,85}
+ doman pbmtools/jbgtopbm.1 pbmtools/pbmtojbg.1
+ fi
+
+ insinto /usr/include
+ doins libjbig/*.h
+ dolib libjbig/libjbig{,85}$(get_libname)
+ use static-libs && dolib libjbig/libjbig{,85}.a
+}