summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-29 20:41:29 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-29 20:41:37 +0100
commit8db8815851f828daae4c9873a87789583bf593ef (patch)
tree42b26da683b088f50a9c79983511364c20a98c88 /media-libs/kvazaar/kvazaar-0.8.3.ebuild
parentremove nova xen from package.use.mask (diff)
downloadgentoo-8db8815851f828daae4c9873a87789583bf593ef.tar.gz
gentoo-8db8815851f828daae4c9873a87789583bf593ef.tar.bz2
gentoo-8db8815851f828daae4c9873a87789583bf593ef.zip
media-libs/kvazaar: bump to 0.8.3
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs/kvazaar/kvazaar-0.8.3.ebuild')
-rw-r--r--media-libs/kvazaar/kvazaar-0.8.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-libs/kvazaar/kvazaar-0.8.3.ebuild b/media-libs/kvazaar/kvazaar-0.8.3.ebuild
new file mode 100644
index 000000000000..972f429e423d
--- /dev/null
+++ b/media-libs/kvazaar/kvazaar-0.8.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ultravideo/kvazaar"
+fi
+
+inherit multilib autotools multilib-minimal toolchain-funcs ${SCM}
+
+DESCRIPTION="An open-source HEVC encoder"
+HOMEPAGE="http://ultravideo.cs.tut.fi/ https://github.com/ultravideo/kvazaar"
+
+if [ "${PV#9999}" = "${PV}" ] ; then
+ SRC_URI="https://github.com/ultravideo/kvazaar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1"
+# subslot = libkvazaar major
+SLOT="0/3"
+IUSE="cpu_flags_x86_avx2 static-libs"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+ASM_DEP=">=dev-lang/yasm-1.2.0"
+DEPEND="${DEPEND}
+ abi_x86_32? ( ${ASM_DEP} )
+ abi_x86_64? ( ${ASM_DEP} )"
+
+src_prepare() {
+ eautoreconf
+}
+
+multilib_src_compile() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --docdir "/usr/share/doc/${PF}" \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_avx2 asm)
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete
+}