summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2021-05-20 00:04:23 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2021-05-20 00:13:15 +0300
commitb22db36af30264f2cde7c55e627cae4a125c0af9 (patch)
tree906cef000df174a9b357dc3e944121711a01601d /media-libs/libafterimage/files
parentgames-sports/torcs: License FreeArt renamed to Free-Art-1.2 (diff)
downloadgentoo-b22db36af30264f2cde7c55e627cae4a125c0af9.tar.gz
gentoo-b22db36af30264f2cde7c55e627cae4a125c0af9.tar.bz2
gentoo-b22db36af30264f2cde7c55e627cae4a125c0af9.zip
media-libs/libafterimage: fix multiple bugs
- Update to EAPI 7 - Use $(AR) if any, fallback to direct ar, bug 731044 - Drop non-standard 'l' from ar args, bug 784182 - Properly detect freetype: use pkg-config, bug 783375 Bug: https://bugs.gentoo.org/784182 Bug: https://bugs.gentoo.org/731044 Bug: https://bugs.gentoo.org/783375 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'media-libs/libafterimage/files')
-rw-r--r--media-libs/libafterimage/files/libafterimage-ar.patch39
-rw-r--r--media-libs/libafterimage/files/libafterimage-freetype.patch23
2 files changed, 62 insertions, 0 deletions
diff --git a/media-libs/libafterimage/files/libafterimage-ar.patch b/media-libs/libafterimage/files/libafterimage-ar.patch
new file mode 100644
index 000000000000..6e8d0bb8cd46
--- /dev/null
+++ b/media-libs/libafterimage/files/libafterimage-ar.patch
@@ -0,0 +1,39 @@
+diff '--color=auto' -Naurd libAfterImage-1.20.orig/Makefile.in libAfterImage-1.20/Makefile.in
+--- libAfterImage-1.20.orig/Makefile.in 2011-01-15 08:52:22.000000000 +0300
++++ libAfterImage-1.20/Makefile.in 2021-05-19 23:32:32.793826120 +0300
+@@ -78,7 +78,8 @@
+ EXTRA_DEFINES = @DEFINE_XLOCALE@
+
+ RANLIB = @RANLIB@
+-AR = ar clq
++AR ?= ar
++AR += cq
+ CP = @CP@
+ MV = @MV@
+ RM = @RM@
+diff '--color=auto' -Naurd libAfterImage-1.20.orig/aftershow/Makefile.in libAfterImage-1.20/aftershow/Makefile.in
+--- libAfterImage-1.20.orig/aftershow/Makefile.in 2011-01-15 08:52:22.000000000 +0300
++++ libAfterImage-1.20/aftershow/Makefile.in 2021-05-19 23:32:53.158905472 +0300
+@@ -11,7 +11,8 @@
+ EXTRA_DEFINES = @DEFINE_XLOCALE@
+
+ RANLIB = @RANLIB@
+-AR = ar clq
++AR ?= ar
++AR += cq
+ CP = @CP@
+ MV = @MV@
+ RM = @RM@
+diff '--color=auto' -Naurd libAfterImage-1.20.orig/apps/Makefile.in libAfterImage-1.20/apps/Makefile.in
+--- libAfterImage-1.20.orig/apps/Makefile.in 2011-01-15 08:52:22.000000000 +0300
++++ libAfterImage-1.20/apps/Makefile.in 2021-05-19 23:33:15.769993568 +0300
+@@ -8,7 +8,8 @@
+ EXTRA_DEFINES = @DEFINE_XLOCALE@
+
+ RANLIB = @RANLIB@
+-AR = ar clq
++AR ?= ar
++AR += cq
+ CP = @CP@
+ MV = @MV@
+ RM = @RM@
diff --git a/media-libs/libafterimage/files/libafterimage-freetype.patch b/media-libs/libafterimage/files/libafterimage-freetype.patch
new file mode 100644
index 000000000000..575a68fd7ca2
--- /dev/null
+++ b/media-libs/libafterimage/files/libafterimage-freetype.patch
@@ -0,0 +1,23 @@
+--- libAfterImage-1.20.orig/configure.in 2011-01-15 08:52:22.000000000 +0300
++++ libAfterImage-1.20/configure.in 2021-05-19 23:40:50.359764859 +0300
+@@ -561,9 +561,9 @@
+ else
+ if test "x$ttf_includes" = "xno"; then
+ AC_MSG_CHECKING(headers required by TTF support)
+- if freetype-config --cflags >/dev/null ;then
++ if pkg-config freetype2 --cflags >/dev/null ;then
+ present_incs="$CCFLAGS $x_includes";
+- for l in `freetype-config --cflags` ; do
++ for l in `pkg-config freetype2 --cflags` ; do
+ inc_found=no
+ for p in `echo "$present_incs"` ; do
+ if test "x$l" = "x$p" ; then
+@@ -636,7 +636,7 @@
+ have_ttf=yes
+ fi
+ if test "$have_ttf" = yes; then
+- AFTERIMAGE_LIBS="`freetype-config --libs` $AFTERIMAGE_LIBS"
++ AFTERIMAGE_LIBS="`pkg-config freetype2 --libs` $AFTERIMAGE_LIBS"
+ fi
+ fi;
+ AC_SUBST(TTF_INCLUDES)