summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libcaca/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libcaca/files')
-rw-r--r--media-libs/libcaca/files/libcaca-0.99_beta18-fix-tests.patch61
-rw-r--r--media-libs/libcaca/files/libcaca-0.99_beta18-latex_hacks.patch14
2 files changed, 75 insertions, 0 deletions
diff --git a/media-libs/libcaca/files/libcaca-0.99_beta18-fix-tests.patch b/media-libs/libcaca/files/libcaca-0.99_beta18-fix-tests.patch
new file mode 100644
index 000000000000..f9ff8090c215
--- /dev/null
+++ b/media-libs/libcaca/files/libcaca-0.99_beta18-fix-tests.patch
@@ -0,0 +1,61 @@
+--- test/Makefile.am
++++ test/Makefile.am
+@@ -1,3 +1,5 @@
++AM_TESTS_ENVIRONMENT = \
++ top_srcdir="$(top_srcdir)"
+
+ AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/caca -I../caca
+
+--- test/check-copyright
++++ test/check-copyright
+@@ -3,10 +3,11 @@
+ #
+ # Check that the copyright information is valid
+ #
++echo "top srcdir: ${top_srcdir:=..}"
+ nfails=0
+ nfiles=0
+ for dir in $(make -s echo-dirs -C ..); do
+- if [ ! -d "../$dir" ]; then continue; fi
++ if [ ! -d "$top_srcdir/$dir" ]; then continue; fi
+ for x in $(make -s echo-sources -C ../$dir); do
+ case "$x" in
+ *.c|*.cpp|*.h|*.m|*.php|*.cs|*.java|.py|.pl)
+@@ -14,7 +15,7 @@
+ *)
+ continue ;;
+ esac
+- if ! grep 'Copyright *([cC])' "../$dir/$x" >/dev/null 2>&1; then
++ if ! grep 'Copyright *([cC])' "$top_srcdir/$dir/$x" >/dev/null 2>&1; then
+ echo "error: $dir/$x lacks proper copyright information"
+ nfails=$(($nfails + 1))
+ elif [ -d ../.git ]; then
+--- test/check-source
++++ test/check-source
+@@ -3,6 +3,7 @@
+ #
+ # Check that we have no tabs or trailing spaces in the source code
+ #
++echo "top srcdir: ${top_srcdir:=..}"
+ nfails=0
+ nfiles=0
+ nlines=0
+@@ -12,15 +13,15 @@
+ case "$x" in
+ *.c|*.cpp|*.h|*.m|*.php|*.cs|*.java|*.py|*.pl)
+ nfiles=$(($nfiles + 1));
+- nlines=$(($nlines + `grep -c . "../$dir/$x"`)) ;;
++ nlines=$(($nlines + `grep -c . "$top_srcdir/$dir/$x"`)) ;;
+ *)
+ continue ;;
+ esac
+- if grep '[[:space:]]$' "../$dir/$x" >/dev/null 2>&1; then
++ if grep '[[:space:]]$' "$top_srcdir/$dir/$x" >/dev/null 2>&1; then
+ echo "error: $dir/$x contains trailing spaces"
+ nfails=$(($nfails + 1))
+ fi
+- if grep ' ' "../$dir/$x" >/dev/null 2>&1; then
++ if grep ' ' "$top_srcdir/$dir/$x" >/dev/null 2>&1; then
+ echo "error: $dir/$x contains tabs"
+ nfails=$(($nfails + 1))
+ fi
diff --git a/media-libs/libcaca/files/libcaca-0.99_beta18-latex_hacks.patch b/media-libs/libcaca/files/libcaca-0.99_beta18-latex_hacks.patch
new file mode 100644
index 000000000000..060822e6dcc7
--- /dev/null
+++ b/media-libs/libcaca/files/libcaca-0.99_beta18-latex_hacks.patch
@@ -0,0 +1,14 @@
+Hack it a bit differently so that it works with texlive 2013, see http://bugs.gentoo.org/480862
+Turns out this patch is required also for texlive 2012, see http://bugs.gentoo.org/517474
+
+--- doc/Makefile.am
++++ doc/Makefile.am
+@@ -29,7 +29,7 @@ if BUILD_DOCUMENTATION
+ if USE_LATEX
+ rm -f latex/libcaca.tex latex/libcaca.pdf
+ mv latex/refman.tex latex/libcaca.tex
+- sed 's/setlength{/renewcommand{/' latex/libcaca.tex \
++ sed 's/\\setlength{/%\0/' latex/libcaca.tex \
+ | sed 's/.*usepackage.*times.*//' > latex/refman.tex
+ cd latex && $(MAKE) $(AM_CFLAGS) refman.pdf || (cat refman.log; exit 1)
+ mv latex/refman.pdf latex/libcaca.pdf