summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libcdaudio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libcdaudio')
-rw-r--r--media-libs/libcdaudio/Manifest1
-rw-r--r--media-libs/libcdaudio/files/libcdaudio-0.99-CAN-2005-0706.patch12
-rw-r--r--media-libs/libcdaudio/files/libcdaudio-0.99.12-bug245649.patch13
-rw-r--r--media-libs/libcdaudio/libcdaudio-0.99.12-r1.ebuild31
-rw-r--r--media-libs/libcdaudio/metadata.xml8
5 files changed, 65 insertions, 0 deletions
diff --git a/media-libs/libcdaudio/Manifest b/media-libs/libcdaudio/Manifest
new file mode 100644
index 000000000000..79c30f8770d3
--- /dev/null
+++ b/media-libs/libcdaudio/Manifest
@@ -0,0 +1 @@
+DIST libcdaudio-0.99.12.tar.gz 357150 SHA256 eb79fa66b3e17424a1a16bb3551108ae32131bea9d6ea0ef3d103d116c506bbc
diff --git a/media-libs/libcdaudio/files/libcdaudio-0.99-CAN-2005-0706.patch b/media-libs/libcdaudio/files/libcdaudio-0.99-CAN-2005-0706.patch
new file mode 100644
index 000000000000..7fc60e367b7d
--- /dev/null
+++ b/media-libs/libcdaudio/files/libcdaudio-0.99-CAN-2005-0706.patch
@@ -0,0 +1,12 @@
+--- libcdaudio-0.99.10/src/cddb.c.orig 2005-04-03 15:37:04.180240520 +0200
++++ libcdaudio-0.99.10/src/cddb.c 2005-04-03 15:38:07.389631232 +0200
+@@ -1034,7 +1034,7 @@
+ }
+
+ query->query_matches = 0;
+- while(!cddb_read_line(sock, inbuffer, 256)) {
++ while(query->query_matches < MAX_INEXACT_MATCHES && !cddb_read_line(sock, inbuffer, 256)) {
+ slashed = 0;
+ if(strchr(inbuffer, '/') != NULL && parse_disc_artist) {
+ index = 0;
+
diff --git a/media-libs/libcdaudio/files/libcdaudio-0.99.12-bug245649.patch b/media-libs/libcdaudio/files/libcdaudio-0.99.12-bug245649.patch
new file mode 100644
index 000000000000..988c4c21c85d
--- /dev/null
+++ b/media-libs/libcdaudio/files/libcdaudio-0.99.12-bug245649.patch
@@ -0,0 +1,13 @@
+--- src/cddb.c
++++ src/cddb.c
+@@ -1679,7 +1679,7 @@ cddb_read_disc_data(int cd_desc, struct disc_data *outdata)
+ free(file);
+
+ while(!feof(cddb_data)) {
+- fgets(inbuffer, 512, cddb_data);
++ fgets(inbuffer, 256, cddb_data);
+ cddb_process_line(inbuffer, data);
+ }
+
+
+
diff --git a/media-libs/libcdaudio/libcdaudio-0.99.12-r1.ebuild b/media-libs/libcdaudio/libcdaudio-0.99.12-r1.ebuild
new file mode 100644
index 000000000000..ec027995a666
--- /dev/null
+++ b/media-libs/libcdaudio/libcdaudio-0.99.12-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Library of cd audio related routines"
+HOMEPAGE="http://libcdaudio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libcdaudio/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.99-CAN-2005-0706.patch #84936
+ epatch "${FILESDIR}"/${P}-bug245649.patch
+}
+
+src_compile() {
+ econf --enable-threads
+ emake || die "compile problem."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/media-libs/libcdaudio/metadata.xml b/media-libs/libcdaudio/metadata.xml
new file mode 100644
index 000000000000..385a5882ed42
--- /dev/null
+++ b/media-libs/libcdaudio/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">libcdaudio</remote-id>
+ </upstream>
+</pkgmetadata>